-1

I have a 64-Bit computer and I am thinking about upgrading it to a 64-bit verson I am trying it out on virtualbox first but i get this error.

Failed to open a session for the virtual machine Linux Mint-64.

VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

closed as off-topic by mikewhatever, George Udosen, Eric Carvalho, karel, Zanna Dec 12 '17 at 10:31

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – mikewhatever, George Udosen, Eric Carvalho, Zanna
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Please enable VT-X in BIOS to use Virtualbox! – George Udosen Dec 11 '17 at 20:07
  • Are you trying to run a 64 bit virtual machine on a 32 bit OS? – ubfan1 Dec 11 '17 at 20:08
  • OP says 64bit computer @ubfan1 – George Udosen Dec 11 '17 at 20:10
  • Did you install 32bit Ubuntu before 'testing' 64-bit? If you did, you can't run a 64bit VM - you're limited by the 32bit architecture of the OS (not the system)> – Thomas Ward Dec 11 '17 at 20:14
  • 1
    I noticed you mentioned "Mint" here, are you using Mint or actual Ubuntu? – Thomas Ward Dec 11 '17 at 20:15
2

Use these steps to enable VT-X in BIOS:

  1. Reboot the computer and open the system's BIOS menu. This can usually be done by pressing the delete key, the F1 key or Alt and F4 keys depending on the system.
  2. Select Restore Defaults or Restore Optimized Defaults, and then select Save & Exit.
  3. Power off the machine and disconnect the power supply.

  4. Enabling the virtualization extensions in BIOS:

    a. Power on the machine and open the BIOS (as per Step 1).

    b. Open the Processor submenu The processor settings menu may be hidden in the Chipset, Advanced CPU Configuration or Northbridge.

    c. Enable Intel Virtualization Technology (also known as Intel VT) or AMD-V depending on the brand of the processor. The virtualization extensions may be labeled Virtualization Extensions, Vanderpool or various other names depending on the OEM and system BIOS.

    d. Enable Intel VTd or AMD IOMMU, if the options are available. Intel VTd and AMD IOMMU are used for PCI passthrough.

    e. Select Save & Exit.

  5. Power off the machine and disconnect the power supply.

  6. Run cat /proc/cpuinfo | grep -E "vmx|svm". If the command outputs, the virtualization extensions are now enabled. If there is no output your system may not have the virtualization extensions or the correct BIOS setting enabled.

Source:

https://docs-old.fedoraproject.org/en-US/Fedora/13/html/Virtualization_Guide/sect-Virtualization-Troubleshooting-Enabling_Intel_VT_and_AMD_V_virtualization_hardware_extensions_in_BIOS.html

  • I used to run Windows 7 Ultimate 64-Bit but during a drive wipe I lost the OS and MBR so the recovery disk was worthless. I use a lenovo X300 and sometimes these older systems are a bit "resistant" to some changes you would like to make. Once I was downloading Window 10 onto my desktop which runs on Windows XP Media Center Edition and it saw what i was doing so it stopped the download and said "Permission Denied" – Fake News Dec 11 '17 at 21:52
  • Just adding to what I just said the BIOS on my computer recieved its last update in January 2009, so I am not sure if thats an option. – Fake News Dec 11 '17 at 21:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.