In Ubuntu 11.10, I can't find a way to change the sub-pixel byte ordering to BGR. I have a BGR monitor and fonts look blurry because of this. I've installed gnome-tweak-tool but I can't find an option for the sub-pixel ordering. This used to be easy to do with the old font settings window.

3 Answers 3


You can do this using a GUI (dconf-editor from the package dconf-tools) or on the command-line:


  1. Open dconf-editor
  2. In the left pane, go to /org/gnome/settings-daemon/plugins/xsettings
  3. In the right pane, change the value of the rgba-order key to bgr:

enter image description here


Just run:

gsettings set org.gnome.settings-daemon.plugins.xsettings rgba-order 'bgr'
  • 2
    What if I have one monitor in portrait, and another in landscape? Can I set the subpixel order for each monitor independently? AFAICT, this is unpossible, but perhaps, I'm missing something? May 28, 2013 at 23:34
  • 1
    Also, Chrome does not seem to use this setting. Is there a way I can set this in Chrome? Aug 14, 2013 at 18:26
  • Command -line for gsettings worked perfectly here, thanks! May 21, 2014 at 12:00
  • 1
    @allyourcode Looking at some possibly related bug reports at crbug.com it seems like Chrome does not really support vertical subpixel layouts and switching to grayscale AA seems to be the only alternative (go to chrome://flags/#lcd-text-aa for that).
    – phk
    Jul 14, 2017 at 13:07

You also may want to change system-wide font settings (and re-login afterwards):

ln -s ../conf.avail/10-sub-pixel-bgr.conf /etc/fonts/conf.d

This fixes sub-pixel rendering on Google Chrome for me, too.

  • This no longer seems to work with Google Chrome version 75.0. I, too, have a BGR display and both Chrome and Firefox do incorrect subpixel rendering. Jun 26, 2019 at 6:17
  • This worked for me in ubuntu 23.04, after chrome and other applications stopped respecting the settings in dconf. make sure to also delete 10-sub-pixel-rgb.conf in the same folder! Jun 22 at 6:48

In latest ubuntu versions (such as 22.10) sub-pixel ordering (RGB/BGR/VRGB/VBGR) is set in dconf-editor under path /org/gnome/desktop/interface/font-rgba-order - such as shown on this screenshot enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .