3

I have a connected a 287TB disk-array to a Ubuntu server. (Both Ubuntu server 14.04 LTS and 16.04 LTS tested) and I have written a GPT and created a single partition using all diskspace:

GNU Parted 3.2
Using /dev/sdb
Welcome to GNU Parted! Type 'help' to view a list of command.
(parted) print
Model: LSI MR9286CV-8e (scsi)
Disk /dev/sdb: 287TB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start    End    Size   File system  Name  Flags
 1      1049kB   287TB  287TB               DAS

However, when I try to create a ext4-filesystem, I get the following error:

ubuntu@ubuntu:~$ sudo mkfs.ext4 -T largefile4 /dev/sdb1
/dev/sdb1: Cannot create filesystem with requested number of inodes while setting up superblock
ubuntu@ubuntu:~$ sudo mkfs.ext4 /dev/sdb1
/dev/sdb1: Cannot create filesystem with requested number of inodes while setting up superblock

However, if I create a partition with a size of 281TB or less, I have no problems.

Isn't it possible to create a ext4 filesystem bigger than 281TB?

| improve this question | | | | |
0

That's happening because you are trying to create a file system on a volume which has 512B block size.

First create a partition with 4K block size and then try to create file system on it.

OR simply use this command.

$ sudo mkfs.ext4 -T largefile4 /dev/sdb1 -b 4096
| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.