0

USB Flash drive is not seen in BIOS, I can't boot from it

HDD is not seen in BIOS (I've installed Ubuntu on it but it doesn't boot)

I tried to change settings in BIOS, they don't get saved after reboot (after save&exit)

I tried to change boot order but my USB Flash or HDD don't appear

Tried with different USB Flash drives, same result

My conclusion is that BIOS is corrupted.

my notebook is an acer aspire E11

What can I do now?

  • 1
    Many BIOSes contain a function to reset memory back to defaults (motherboard manual should tell you how, be it short or jumper a connection for a few secs, removing battery and ...) so I would suggest following those instructions. I'd suggest inspecting your motherboard anyway (clean & capacitor scan for signs of why its misbehaving & whether its worth any time trying to fix...) [these suggestions are hardware related] – guiverc Dec 11 '17 at 7:00
  • thank you for your suggestion, tried it, doesn't work; my HDD is seen by BIOS in the first tab but in the tab with boot order doesn't appear, and strangely enough my old HDD is listed (now removed and replaced) – Stefan Dec 11 '17 at 20:49
  • Have you checked your CMOS battery? If it is dead then it might be causing the problem. Replace with a new one and then try to change and save BIOS settings. – Manish Kumar Bisht Dec 13 '17 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.