0

I have a Thinkpad T430, the version with Core i7 2.9 GHz which, according to this specs page, should have an nVidia hybrid GPU from the factory. I'm using Ubuntu Mate 16.04.3 LTS. I have (according to Ubuntu) 2x 4GB 1600 MHz DDR3 RAM modules, total 8 GB RAM, and a 320 GB 7200 rpm platter hard disk, with 100+ GB free in my /home, and 20+ GB free in /.

However, after a recent incident where attempting to use bumblebee and nVidia Prime (switching from Prime to bumblebee when Prime didn't seem to work) led to loss of keyboard and mouse response at login screen, I ended up reinstalling Ubuntu as the fastest way to restore function (now working fine, fully restored).

After reinstalling Ubuntu, I tried installing nVidia drivers and bumblebee again (from the graphics-drivers ppa, which gives a much more current version than the standard Ubuntu repos), and noted that while both driver and bumblebee installed, bumblebee complained during installation that no discrete graphics card was detected. I didn't see anything similar with the nVidia drivers, but to be honest, I wasn't really looking yet when I ran that install.

At that point, to avoid starting over on my reinstallation by recreating the previous failure, I removed the bumblebee packages and the nVidia drivers. The machine is running fine on the Intel graphics, but there's reason to believe that the heavy RAM usage by the integrated graphics is causing a performance issue with a favorite game (Kerbal Space Program), because of the way the graphics uses system RAM.

A pretty prolonged search found no answers to similar questions newer than 2015, and the newer of those were founded on the assumption that the hardware was known to be present, or that lspci would report it as a "3D Controller" -- which does not occur on my system.

For instance, this doesn't show any video hardware except the Intel:

sudo lshw -C video
[sudo] password for [user]:

*-display          

   description: VGA compatible controller
   product: 3rd Gen Core processor Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 09
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:27 memory:f0000000-f03fffff memory:e0000000-efffffff 
ioport:5000(size=64) memory:c0000-dffff

Now for the real question: is there a reliable way, without either nvidia-prime or bumblebee, bumblebee-nvidia, and primus installed and working, to determine for certain that my machine does or does not have the nVidia GPU that Lenovo seems to say was present in T430 systems with this CPU? I don't see any way or reason the GPU might have been removed during the refurb (and have the computer still operate -- it'd be soldered, rather than socketed, right?), but I haven't been able to get any software test I've tried to admit it's present. There is an empty space under the RAM cover; it appears to be a mini-PCIe for an optional cellular broadband modem that was offered for this model. I found a maintenance manual online, it shows where the GPU would be mounted if present, and it's not accessible without disassembly (top of the logic board, under the upper right of the keyboard). It doesn't, however, specify which exact models have the GPU. The exact model number is available in BIOS or via lshw (don't have it with me, I'm at work now).

  • What is your the output of: sudo lshw -C video. Can you share, please? – estibordo Dec 10 '17 at 17:02
  • I've edited that command result into the post. – Zeiss Ikon Dec 10 '17 at 20:35
  • Just one more info, please. Run sudo dmidecode | grep -A3 '^System Information' to check your T430 model and sudo dmidecode -s processor-version to make sure you have the Core i7 2.9 GHz. – estibordo Dec 10 '17 at 21:48
  • 1
    Check your BIOS. You might have disabled optimus (and you have "UMA" only enabled). – estibordo Dec 10 '17 at 21:58
  • @estibordo I've been through the BIOS from end to end, top to bottom, several times. There's nothing there about optimus. Your first command, ending with "-A3" returns an error from grep; the second (as expected) confirms "Intel (R) Core(TM) i7-3520M CPU @ 2.9 GHz". – Zeiss Ikon Dec 11 '17 at 0:58
1

sudo lshw -C video is a reliable way to find out existent GPUs. On your lshw -C video output, there is only one GPU listed.

If you check the Lenovo website, the two GPUs (Intel and nVidia) maybe present. If you check each model here, for example, some models have two GPUs, while others just have the Intel based one.

Your model have just one GPU.

  • The CNet site you point to is the same one I linked in my question. The only model they list that has the i7-3520 2.9 GHz CPU is listed as also having the nVidia NVIDIA NVS 5400M GPU in addition to the Intel graphics. That said, I still haven't seen any evidence this computer actually has the nVidia GPU; it may be that Lenovo sold multiple i7 models, some with and some without nVidia, as well as different hard disks (my HDD is 320 GB rather than the 500 they list). – Zeiss Ikon Dec 11 '17 at 1:04
  • Additional confusion: the model number listed in both BIOS and the full lshw is one that was sold with an i5, yet just a couple lines down, it clearly shows the i7 -- and Lenovo's own site just says "this model is no longer sold" and offers me BIOS updates and driver downloads. – Zeiss Ikon Dec 12 '17 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.