1

My hardware: Core 2 Quad + Asrock 775i65g + 2Gb RAM + ASUS AH3450 AGP 256 Mb + 2 19 inch screens (second one conected to DVI port via AGP-DVI adapter).

I'm having lots of X server isues.

  • If the screen spontaneously turns off due to power management, I only manage to get a black screen for the X server after that. I can login via tty1 and restart my computer. This always happens.
  • Sometimes the computer freezes completely and it can only be manually restarted.
  • Sometimes the X screen goes black but the computer didn't froze. The kernel was sending lots of messages like this:

[ 7713.074700] [TTM] AGP Bind memory failed

[ 7713.074751] [drm:radeon_gem_object_create [radeon]] ERROR Failed to allocate GEM object (819200, 2, 4096, -16)

[ 7713.305215] [TTM] AGP Bind memory failed

[ 7713.305365] [drm:radeon_gem_object_create [radeon]] ERROR Failed to allocate GEM object (1310720, 2, 4096, -16)

Kernel can attempt a recovery in this situation, often without success:

[ 1777.483908] radeon 0000:01:00.0: f5294000 unpin not necessary

[ 1777.484080] radeon 0000:01:00.0: Saved 3001 dwords of commands on ring 0.

[ 1777.484094] radeon 0000:01:00.0: GPU softreset: 0x00000009

[ 1777.484096] radeon 0000:01:00.0: R_008010_GRBM_STATUS = 0xA2723030

[ 1777.484099] radeon 0000:01:00.0: R_008014_GRBM_STATUS2 = 0x00000103

[ 1777.484101] radeon 0000:01:00.0: R_000E50_SRBM_STATUS = 0x200000C0

[ 1777.484103] radeon 0000:01:00.0: R_008674_CP_STALLED_STAT1 = 0x00000000

[ 1777.484105] radeon 0000:01:00.0: R_008678_CP_STALLED_STAT2 = 0x00008002

[ 1777.484107] radeon 0000:01:00.0: R_00867C_CP_BUSY_STAT = 0x00008086

[ 1777.484109] radeon 0000:01:00.0: R_008680_CP_STAT = 0x80018645

[ 1777.484112] radeon 0000:01:00.0: R_00D034_DMA_STATUS_REG = 0x44C83D57

[ 1777.545627] radeon 0000:01:00.0: R_008020_GRBM_SOFT_RESET=0x00007FEF

[ 1777.545681] radeon 0000:01:00.0: SRBM_SOFT_RESET=0x00000100

[ 1777.547771] radeon 0000:01:00.0: R_008010_GRBM_STATUS = 0xA0003030

[ 1777.547773] radeon 0000:01:00.0: R_008014_GRBM_STATUS2 = 0x00000003

[ 1777.547775] radeon 0000:01:00.0: R_000E50_SRBM_STATUS = 0x200080C0

[ 1777.547777] radeon 0000:01:00.0: R_008674_CP_STALLED_STAT1 = 0x00000000

[ 1777.547779] radeon 0000:01:00.0: R_008678_CP_STALLED_STAT2 = 0x00000000

[ 1777.547781] radeon 0000:01:00.0: R_00867C_CP_BUSY_STAT = 0x00000000

[ 1777.547783] radeon 0000:01:00.0: R_008680_CP_STAT = 0x80100000

[ 1777.547786] radeon 0000:01:00.0: R_00D034_DMA_STATUS_REG = 0x44C83D57

[ 1777.547796] radeon 0000:01:00.0: GPU reset succeeded, trying to resume

[ 1777.561712] radeon 0000:01:00.0: WB disabled

[ 1777.561717] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x00000000e0000004 and cpu addr 0xf8531004

[ 1777.567974] radeon 0000:01:00.0: fence driver on ring 5 use gpu addr 0x00000000d00521d0 and cpu addr 0xf90121d0

[ 1777.599306] [drm] ring test on 0 succeeded in 1 usecs

[ 1777.773970] [drm] ring test on 5 succeeded in 1 usecs

[ 1777.773979] [drm] UVD initialized successfully.

[ 1777.909867] [drm] ib test on ring 0 succeeded in 0 usecs

[ 1778.585173] [drm] ib test on ring 5 succeeded

Additional info: In windows XP, if I run firefox in the secondary screen it lags a lot and freezes after some time; but XP doesn't exhibit these problems and runs very stable in other situations. However in Ubuntu this happens even when there is nothing in the secondary screen and I'm just opening a file browser on the primary; these situations can significantly hamper computer use. The hangs happen in both RAM constrain situations and normal situations. They were present in Ubuntu 16.04 LTS so I upgraded to the latest version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.