7

My Bose QuietComfort 35 bluetooth headphones disconnect after a few seconds in Ubuntu 17.10. They used to work fine under Ubuntu 16.04. After a restart, the same thing happens again. I can not reconnect the headphones without restarting.

I tried to use the solutions for the pairing problem (Pair Bose QuietComfort 35 with Ubuntu over Bluetooth), but the problem persists. Also, as far as I have seen the other questions concerning these headphones, this seems to be a different problem.
This is the result for the service bluetooth status after the phones disconnect:

● bluetooth.service - Bluetooth service  
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)   
   Active: active (running) since Sat 2017-12-09 22:34:21 CET; 1min 58s ago   
     Docs: man:bluetoothd(8)   
 Main PID: 742 (bluetoothd)   
   Status: "Running"   
    Tasks: 1 (limit: 4915)   
  CGroup: /system.slice/bluetooth.service   
          └─742 /usr/lib/bluetooth/bluetoothd   

Dez 09 22:34:21 mycomputer systemd[1]: Starting Bluetooth service...   
Dez 09 22:34:21 mycomputer bluetoothd[742]: Bluetooth daemon 5.46   
Dez 09 22:34:21 mycomputer systemd[1]: Started Bluetooth service.   
Dez 09 22:34:21 mycomputer bluetoothd[742]: Starting SDP server   
Dez 09 22:34:21 mycomputer bluetoothd[742]: Bluetooth management  interface 1.14 initialized   
Dez 09 22:34:30 mycomputer bluetoothd[742]: Endpoint registered: sender=:1.77 path=/MediaEndpoint/A2DPSource   
Dez 09 22:34:30 mycomputer bluetoothd[742]: Endpoint registered: sender=:1.77 path=/MediaEndpoint/A2DPSink   
Dez 09 22:35:08 mycomputer bluetoothd[742]: /org/bluez/hci0/dev_04_52_C7_31_07_DE/fd0: fd(37) ready  
Dez 09 22:35:54 mycomputer bluetoothd[742]: Start: Connection timed out (110)   
Dez 09 22:35:56 mycomputer bluetoothd[742]: Abort: Connection timed out (110)   
  • 1
    I have exactly the same problem. Has anyone solved this? Please help... – zarzyk Jan 6 '18 at 12:13
  • I also have exactly the same problem! Any solution to this yet? – Edvin Apr 19 '18 at 6:19
  • it just suddenly worked with me, I don't know why. Maybe some update. I hope it still works with Ubuntu 18.04 when it comes out next week ;) – sebastian Apr 20 '18 at 8:20
  • 2
    @sebastian: It looks like It's not only Bose which is having a problem. My headphone was having the same issue additionally it always used to connect to HSP/HFP instead of A2DP until I restart my computer. For many days I used a workaround using a script which you can also try from here: gist.github.com/pylover/d68be364adac5f946887b85e6ed6e7ae. Later I install blueman and always used my headset to connect using it. I still don't know how it fixed the issue but I don't have to restart my system anymore.. Lol! – Saurav Kumar Apr 21 '18 at 18:46
  • I paired my device with blueman and it works fine. – Hooman Oct 26 '18 at 16:32
0

What helps for me (Ubuntu 18.04) is do remove the device in the Bluetooth settings and then reconnect. After that, the connection is stable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.