1

This question already has an answer here:

I have recently installed Ubuntu for the first time and it is running exceptionally slow.

Version:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.3 LTS
Release:    16.04
Codename:   xenial

Processes:

top - 14:33:41 up  1:12,  1 user,  load average: 1.16, 1.63, 1.59
Tasks: 174 total,   1 running, 173 sleeping,   0 stopped,   0 zombie
%Cpu(s):  9.6 us,  0.7 sy,  0.0 ni, 88.4 id,  1.3 wa,  0.0 hi,  0.0 si,  0.0 st
KiB Mem : 11753128 total,  8966964 free,  1897648 used,   888516 buff/cache
KiB Swap: 12024828 total, 12024828 free,        0 used.  9507028 avail Mem 

  PID USER      PR  NI    VIRT    RES    SHR S %CPU %MEM     TIME+ COMMAND      
  890 root      20   0  581064 176596  57956 S  6.3  1.5  23:49.16 Xorg         
 2297 ollie     20   0 2082488 240708 103988 S  2.3  2.0   1:23.95 Web Content  
 1682 ollie     20   0 1405520 341920  76848 S  1.7  2.9  12:16.67 compiz       
 1980 ollie     20   0 2391632 364112 145216 S  0.3  3.1   3:39.87 firefox      
 2055 ollie     20   0 2109904 202328 100968 S  0.3  1.7   2:00.45 Web Content  
 2759 root      20   0       0      0      0 S  0.3  0.0   0:00.04 kworker/u2:0 
 2828 ollie     20   0 1947012 242732 125488 S  0.3  2.1   0:40.05 Web Content  
    1 root      20   0  119988   6056   3900 S  0.0  0.1   0:01.19 systemd      
    2 root      20   0       0      0      0 S  0.0  0.0   0:00.00 kthreadd 

My graphics controller:

VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Carrizo [1002:9874] (rev c5) (prog-if 00 [VGA controller])

For which I have installed graphics drivers using sudo apt-get install amd64-microcore. My laptop specs do not warrant the slow behaviour, which is AMD Quad-Core A10-8700P APU with Radeon™ R6 Graphics (1.8 GHz, up to 3.2 GHz, 2 MB cache) and 12 GB RAM.

Does anyone have any idea why it may be running so slowly?

Edit:

Using lspci -nnk | grep -A4 VGA returns the following:

VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Carrizo [1002:9874] (rev c5)
    DeviceName: ATI EG BROADWAY
    Subsystem: Hewlett-Packard Company Carrizo [103c:80ba]
    Kernel modules: amdgpu
00:01.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Kabini HDMI/DP Audio [1002:9840]

marked as duplicate by David Foerster, Fabby, Zanna, Elder Geek, karel Dec 15 '17 at 2:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Microcode is actually for the CPU. To see which driver is used for the graphics, run lspci -nnk | grep -A4 VGA, and add the output to the question. – mikewhatever Dec 9 '17 at 15:36
  • 1
    So, it's amdgpu, as expected. It shouldn't be slow, but perhaps you can provide a few examples of 'running exceptionally slow'. What exactly is slow? Program loading? Tab or window switching? Animations and effects? If you suspect the GPU is to blame, try Unity's low graphics mode. – mikewhatever Dec 9 '17 at 18:56
  • @mikewhatever I tried installing amdgpu but I got into an infinite loop which rebooted every time I tried to login and had to remove it. All the stuff you mention is slow- typing, animations, the mouse is laggy and jumpy. Program loading appears slow too. – obackhouse Dec 9 '17 at 19:09
  • I just checked and low graphics mode was enabled - it seems to be even worse with it on. – obackhouse Dec 9 '17 at 19:29
  • According to support.amd.com/en-us/kb-articles/Pages/… your APU isn't supported by the AMDGPU driver which means there is currently no way to improve the graphics performance of your system under Linux. Thank your APU manufacturer for not supporting their own product in this (niche) market. – David Foerster Dec 12 '17 at 9:14
2

I appear to have fixed it: I had nomodeset in the boot options, removing it has reduced the choppiness and animation lag.

Not the answer you're looking for? Browse other questions tagged or ask your own question.