1

This is my laptop's data sheet: http://www8.hp.com/h20195/v2/GetPDF.aspx/c05342156.pdf
Hello, I am having an issue in Ubuntu 17.10. If I suspend the laptop (whether it be through the menus or by closing the lid), GNOME glitches out after I resume the laptop. What I mean by that is, when I resume, every time I press an icon on the Dock, it opens a new window instead of showing the currently opened window and every new link or tab is opened in a separate window in Firefox (both regular and Nightly).
Can someone explain what is going on and how to fix this?
Also, in case this is somehow useful, I'm using logical volumes instead of separate partitions and hibernation leaves the laptop powered on.
Thank you kindly in advance!
Edit: After some testing, I have concluded that my suspicions were accurate, that is that the issue is GNOME-related and not related to the window manager behind the currently-running desktop environment (or, in other words, it's not a question of Wayland or Xorg, but GNOME and Unity, and it's working just fine in Unity), so this might be a GNOME3 bug. All that's missing now is a working fix for the Realtek ALC295 issue I'm having.
Edit: After some experimenting with KDE Plasma, I have found that this is an issue that goes beyond GNOME (yet is somehow avoided by Unity).

  • Are you using a Wayland (default) or a Xorg session? One can choose that at login by clicking the little gear symbol – if Wayland, could you try if it occurs in a Xorg session as well? – dessert Dec 8 '17 at 22:52
  • @dessert I knew someone would mention it. I didn't have time to test it out in Xorg (I thought trying it out in Unity since I doubt Xorg itself would make a difference since everything mentioned is Wayland compatible, or at least I assume for Firefox since I saw plans towards Wayland support some four years ago, if not earlier). Thank you for reminding me. – Sandy Vujaković Dec 9 '17 at 13:14
  • When I resume from suspend, I see all the desktop windows for a few seconds before the lock screen is presented, where I am prompted to enter my password. Do you also experience this? Also, what graphics are you using (Intel, Nvidia, AMD)? – PJ Singh Jan 29 '18 at 2:14
  • @PJSingh AMD Radeon R7 M440. That's standard in GNOME, I disabled it in Settings (>Privacy>Screen lock), but I wouldn't know about it with suspending since I disabled it before I first suspended the laptop, although it never showed after that, so that's probably the solution. My issue is as stated above. – Sandy Vujaković Jan 30 '18 at 20:44
  • My HP Spectre x360 as the Nvidia chip, and I was unable to resume from suspend if I used the Nvidia dedicated graphics. But when I use the integrated Intel graphics of my CPU, suspends works OK (except for the small issue I described above). Is there a way to uninstall the graphics drivers for your dedicated AMD video chip, instead of just disabling it? (I think that would mean uninstalling fglrx, but it's been years since I've had an AMD graphics card). Might be worth trying, if you are willing to experiment with your installation. – PJ Singh Jan 31 '18 at 0:09
0

my problem with resume from suspend is the computer reboots instead of waking. I still cant get an answer either. I thought maybe it was wayland, but i went back to xorg session and the problem persists.

  • This would be a comment, not an answer, so don't write it in the answer section. – Sandy Vujaković Mar 26 '18 at 14:42
0

So, with the upgrade to Ubuntu 18.04 Bionic Beaver, a few updates later, the issue has been resolved. I believe it was an issue with the version of GNOME supplied with Ubuntu 17.10 Artful Aardvark (3.26, if I remember correctly, and in Bionic it's 3.28). 🙂

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.