1

I'm using Kubuntu 17.10 (fully updated). This problem may have been introduced during the upgrade to 17.04 or 17.10; I can't be sure, since I did both upgrades back to back.

Everything works as expected in the Konsole, but file names with non-ASCII characters are displayed with Unicode replacement characters (��) in KDE applications (Dolphin, Kate, etc). The display is different in other GUI applications like LibreOffice, but the file still cannot be opened. I also noticed that xterm doesn't default to UTF-8 mode anymore; this may be related.

Screenshot

I have tried both dpkg-reconfigure locales and apt install --reinstall locales, but didn't see any change after rebooting.

/etc/default/locale:

LANG=en_US.UTF-8
LC_NUMERIC="de_AT.UTF-8"
LC_TIME="de_AT.UTF-8"
LC_MONETARY="de_AT.UTF-8"
LC_PAPER="de_AT.UTF-8"
LC_NAME="de_AT.UTF-8"
LC_ADDRESS="de_AT.UTF-8"
LC_TELEPHONE="de_AT.UTF-8"
LC_MEASUREMENT="de_AT.UTF-8"
LC_IDENTIFICATION="de_AT.UTF-8"

locale in Konsole (these values are set in my .bashrc):

LANG=de_AT.utf8                                                                                                                                                                                                                              
LANGUAGE=                                                                                                                                                                                                                                    
LC_CTYPE=de_AT.utf8                                                                                                                                                                                                                          
LC_NUMERIC=de_AT.utf8                                                                                                                                                                                                                        
LC_TIME=en_GB.utf8                                                                                                                                                                                                                           
LC_COLLATE=POSIX                                                                                                                                                                                                                             
LC_MONETARY=de_AT.utf8
LC_MESSAGES=en_US.utf8
LC_PAPER=de_AT.utf8
LC_NAME=de_AT.utf8
LC_ADDRESS=de_AT.utf8
LC_TELEPHONE=de_AT.utf8
LC_MEASUREMENT=de_AT.utf8
LC_IDENTIFICATION=de_AT.utf8
LC_ALL=

locale -a:

C
C.UTF-8
POSIX
de_AT
de_AT.iso88591
de_AT.iso885915@euro
de_AT.utf8
de_AT@euro
de_BE.utf8
de_CH.utf8
de_DE.utf8
...
en_GB.utf8
...
en_US.utf8

(Full list.) I do not remember installing all those locales; I only selected de_AT.iso88591, de_AT.utf8, de_AT@euro, de_DE.utf8, en_GB.utf8, en_US.utf8.

I'm also unsure of whether to specify UTF-8 locales as de_AT.utf8 or de_AT.UTF-8... both seem to be used.

What should I do now?

  • 2
    Use de_AT.UTF-8 for declaring. it probably should be enough if you use the UI tools to re-set the language and data formats systemwide. Declaring language variables should not be needed in .bashrc. – Videonauth Dec 8 '17 at 17:46
  • Did you try reinstalling from scratch? That's what I would do. I have a packer template for building Ubuntu 17.10 gitlab.com/jcrben-play-learn/packer-desktop – Ben Creasy Feb 18 '18 at 20:37
1

KDE overwrites your locale. change your region to a supported region.

0

In KDE (Kubuntu 18.04) System settings and in Regional Settings, I added language and formats (for Region, numbers, time, currency, measurement units) and after a reboot, I was able to use Dolphin, without those non-ASCII characters in the file and folders.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.