I recently installed Ubuntu 11.10 with Unity to dual boot with windows 7 on my lap top. My laptop is running an Intel i7 quad-core and 8gb of RAM just as some background. I've noticed that when I'm running Ubuntu, my computer heats up a lot more than windows 7 and it seems like the battery life is a lot shorter. Using system monitor, I've seen that my computer goes through cycles of having 100% CPU usage to 20% to 1-3% and then back to 100% CPU usage. It does not, however, list the process that is eating up all this cpu (though occasionally, the gnome-system-monitor process is using 20% of my cpu). I was wondering what the problem is here? Is it a problem with unity? or is there something else going on? Mostly, when this is happening, I'm just using chrome or firefox, or empathy. Whats happening?

  • Have you tried logging in with Unity 2D to see if the problem is still there? Because I think it can be related to the video card driver. – heiko81 Jan 25 '12 at 15:29
  • Just found this thread looking for solution to same problem. Not a 3D problem, I've been using Unity 2D exclusively since 11.10 came out, on my Intel i3 2367 HD 3000 laptop. Same problem. – Kurtosis Apr 6 '12 at 4:59
  • cpu cranks up a lot when flash movies or youtube videos are being played. – enthusiasticgeek Apr 29 '12 at 14:47
  • Try this article that I saw on Hacker News. It might be relevant, although it mostly affects Java applications. – fouric Jul 2 '12 at 22:46

By default, System Monitor will only display your own processes. You can show system processes by selecting Show -> All processes from the menu bar. Unity itself would never show up in the process list since it's just a plugin for Compiz. So if Unity was the problem, then Compiz would show a high CPU usage. Compiz 0.9 is slower than 0.8, this is confirmed. However, I see no reason why Unity itself should be very demanding, or why you would think so.

11.04 and 11.10 were two very special versions in that there were large amounts of changes in the underlying system. As an example, my laptop had a battery life of about 5.5 hours on 10.04, 4.5 hours on 11.04 and 4 hours on 11.10. I've upgraded it to the development version of 12.04 (Precise Pangolin) and now it's back at about 5.5 hours.

All this is to say that you're not imagining it. Specially 11.10 has been very power hungry, and there is no single piece of software to blame. The Linux kernel has had some power issues as well, for instance. My desktop sounded like a Harley Davidson in 11.10, but not it's completely silent again. So it's a problem with 11.10 in general, and 12.04 fixes it on all my computers. While I don't want to recommend that you upgrade to it yet, at least it should be comforting to know that it'll most likely fix all those issues, and that it'll be available in the not so distant future.


In system monitor select View All Processes.

In my case it was popularity-cont that was eating cpu.

It is part of the Ubuntu popularity contest which finds out what packages you have been using. That's fine, but not if it intrudes.

  • You're right that popularity-contest should never take up substantial CPU resources. I recommend reporting this as a bug in popularity-contest in Ubuntu. The best way to initiate the report would be, when the problem occurs, to run ubuntu-bug with the PID of the running popularity-cont process (the linked guide explains this in detail). If you want to disable popularity-contest, open Software Sources (one way is to click Settings... in the Update Manager) and uncheck "Submit statistical information" in the Statistics tab. – Eliah Kagan Jul 2 '12 at 22:45

I cut my cpu usage down to almost 0, when idle, by doing these three things.

  1. I uninstalled Mozilla Firefox. (I use Opera web browser)
  2. I discovered VLC Media Player constantly running in the background. (Be sure you also don't have a program eating up your processor power)
  3. I installed BLEACHBIT to devour unused data and/or clean up unwanted processes trying to act on that data.

SUCCESS! I changed my dual core processors from one running maxed out and the other at 20% or more ALL the time.

I run UBUNTU 12.04 LTS stand-alone on a 5 year old Lenovo desktop, fresh install one week ago.


You should check with "top" in a terminal. I have a similar problem with plugin-container, it seems a known problem, look here for example:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.