1

A few days ago, I opened Chromium with a temporary profile.
Since then whenever I open chromium by clicking its icon or from the dash, I get a temporary user profile Chromium window.

However, If I open it from the terminal, it shows the right profile, with all my history, my Download location, Bookmarks...

Things I have tried:

  1. Uninstalling Chromium and reinstalling it.
  2. Purging the "chromium-browser", deleting /home/username/.config/chromium and then reinstalling it. Even if I do not restore the folder's contents, and just use a new profile, chrome does not store passwords, history or bookmarks. It always opens in a new temporary user profile.

Below you can see the difference between Opening chrome from the icon and opening it from the terminal command chromium-browser:

Chromium browser from the terminal

Chromium from the browser icon

Here's a link to my previous question.

1 Answer 1

1

Trying the following fix may help to fix your problem with chromium browser.

1. Open a terminal and run the following commands.

cp  /usr/share/applications/chromium-browser.desktop ~/.local/share/applications/

gedit ~/.local/share/applications/chromium-browser.desktop

The file will open now and find the first line in the file that begins with Exec=. This should be under the category [Desktop Entry]

2. Replace the line by Exec=chromium-browser

3. Save the file and logout and try again. This should fix the issue.

Note : In your case i think the first line start with Exec= would be Exec=chromium-browser --temp-profile. If yes, disable it using # and add the new entry above that.

The above methode will load your default user profile. If you have multiple profiles, you may need to specify which profile should be opened by default using --user-data-dir=DIR option in the file described above. see the man page of chromium-browser for more info.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .