5

I use Bluetooth for my headphones and it used to work more or less in Ubuntu 17.10 (had to redo the pairing process sometimes but then it worked out). After I installed Dash-to-Panel-Extension for GNOME for whatever reason the Bluetooth adapter turned off and won't turn on again.

In my Bluetooth settings it says 'Bluetooth Turned Off'. I can push the button to turn it on, but nothing happens.

Also I can press the "turn on" button in the Panel, but nothing happens.

https://i.stack.imgur.com/MpTwO.png

Things I've tried:

  • Deactivating Dash-to-Panel Extension (and restart computer)
  • sudo service bluetooth start
    
  • sudo apt-get install --reinstall bluez
    
  • reinstalled all Bluetooth components with

    sudo apt install bluez bluez-cups bluez-obexd gnome-bluetooth indicator-bluetooth libbluetooth3:amd64 libgnome-bluetooth13:amd64 pulseaudio-module-bluetooth
    
  • Different variations of turning the bluetooth switch of my laptop off and on and restarting

  • rfkill list all
    

    Output:
    enter image description here
    (so it seems not to be blocked)

  • lspci -knn | grep Net -A3; lsusb; dmesg | grep -i blue
    

    Output:
    enter image description here
    (again seems not to be blocked)

  • bluetoothctl list
    
    Output: enter image description here

Now I'm running out of ideas. Are there any other approaches?

  • Are there any options in BIOS? There isn't anything reported in lsusb results that would be a bluetooth device – Jeremy31 Dec 8 '17 at 19:19
  • I checked the BIOS: Under Security --> I/O Port Access I found an Option for Bluetooth. It was "enabled". I clicked it...selected "enabled" again (so basically changed nothing), saved and rebooted. To my surprise bluetooth now was activated in Ubuntu! To my further surprise...my Headset can not be connected now. It is found under devices, but for some reason can't connect. – UbuntuNoob Dec 9 '17 at 12:34
  • See if askubuntu.com/a/837732/300665 fixes that. It will likely be needed to use the headphones after every disconnect/reboot because of some stubborn bug – Jeremy31 Dec 9 '17 at 12:47
  • For the resulting connection problem with my headset [this] (askubuntu.com/questions/789088/…) worked. – UbuntuNoob Dec 9 '17 at 13:01
0

As loge as it's not your hardware problem an upgrade will fix it (probably) so consider upgrading to latest stable release.

Note: before you do so make bootable device and check if it's not your hardware problem by running a live Ubuntu OS. if Bluetooth works in live mode consider upgrading to latest LTS release
it will fix the issue. last time i had the issue i done the something it worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.