1

I'm running Ubuntu 16.10 desktop with Kernel 4.8.0-22-generic. I'm trying to enable PCI AER reporting.

/boot/config-`uname -r` shows

CONFIG_ACPI_APEI_PCIEAER=y
CONFIG_PCIAER=y
CONFIG_PCIEPORTBUS=y

so clearly AER reporting has been enabled. Yet in dmesg I see this:

acpi PNP0A08: _OSC: platform does not support [AER]

I have tried this on several systems with different SuperMicro motherboards and I see the same message.

Any idea what is going wrong and what can be done to solve the problem?

1

No all motherboard has PCIe AER capable root complex. Also, I would check you don't have pci=noaer in your kernel boot argument.

0

Instead of CONFIG_PCIAER=y try CONFIG_PCIEAER=y.

  • 3
    Welcome to AU. Could you provide more information on the reason why you think it will work? – Marc Vanhoomissen Apr 24 '18 at 11:37
0

PCI AER is disabled by default in the BIOS of SuperMicro machines. To check if yours is as well, either load up BIOS and look under ACPI settings, or search "AER" in your motherboard's manual.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.