11

When I try to open folders (and the trash can) by double-clicking on them on the desktop nothing happens. However, when I right-click on the folder, select "Open with another application", and then select Nautilus it opens normally. I think that it has something to do with the default file manager maybe? (I can open other files that aren't folders normally)

  • In the control center, under Personal then in Preferred Applications, what is your "preferred" file manager? – jpezz Dec 7 '17 at 19:50
  • @jpezz there isn't any File Manager category on the Preferred Applications page, just "Web", "Mail", "Calendar", "Music", "Videos" and "Pictures" (or something like that, my OS's language isn't English, it's Portuguese) – luplaxx Dec 9 '17 at 2:23
  • "$mate-default-applications-properties" should bring up the window. with 5 tabs: Internet Multimedia System Office Accessibility. It's under "System". I have 17.04 so it may be changed for 17.10. – jpezz Dec 11 '17 at 21:51
  • @jpezz , I opened the window and set my default file manager to "Files", but the issue continues, I still can't open directories from my desktop by double-clicking... – luplaxx Dec 12 '17 at 22:59
5

My system is Ubuntu 17.10.

I just had this problem 5 mins ago. Here is my solution.

Just install gnome-tweak

sudo apt install gnome-tweak-tool

Then turn off and turn on some of the options in the Desktop. Like show icons turn on and turn off. Then it seems like things are refreshed and everything works again!

Click here

  • 1
    dosn't work for me – pedram shabani Mar 22 '18 at 10:34
  • 1
    it doesn't work for me either – Trevor Hickey Jun 7 '18 at 20:16
  • 1
    works for me 18.04 – MaxySpark Jun 8 '18 at 8:14
  • 2
    but after sometime again not working 😅 – MaxySpark Jun 8 '18 at 8:16
  • 1
    does not work for me either – Francesco Boccardo Feb 1 at 15:19
2

The best solution which worked for me is to use the following commands:

sudo apt-get purge nautilus  

sudo apt-get install nautilus

nautilus --check
  • 1
    How long did you have to wait? For me in ubuntu 18.04 the last command seems to hang after it displays running nautilus_self_check_directory. – snark Apr 17 at 19:49
0

I know that this isn't a direct solution to the problem (that I was having too), but my choice was to install another File manager altogether. I chose Nemo. This is how you integrate Nemo in Ubuntu taking the place of Nautilus (the culprit here).

  1. First of all you install Nemo as explained here: INSTALL NEMO
  2. Then you set Nemo as your default File Manager as shown here: DEFAULT NEMO
  3. Then, if you want to have Nemo display the standard icons on the Desktop like Home, Computer, Network, Recicle Bin, etc..., you need to enable some settings. I am quite sure you can do it in the Terminal but I chose to install the GUI "dconf-tools"

    sudo apt-get install dconf-tools
    

    and then launch the GUI by issuing

    dconf-editor
    

    The settings that you need to change are located in "/org/nemo/desktop". They are pretty self-explicative.

I hope that this have been useful to you.

0

The problem is an old xfce installation or the package "exo-utils". Remove "exo-utils". This is an well known and older problem:

Code:

sudo apt-get remove --purge exo-utils

And everything worked as expected.

  • When this command is issued I got notification that the following will be also removed exo-utils thunar thunar-archive-plugin thunar-media-tags-plugin thunar-volman xfce4 xfce4-cpufreq-plugin xfce4-cpugraph-plugin xfce4-goodies xfce4-mailwatch-plugin xfce4-notes-plugin xfce4-panel xfce4-panel-dev xfce4-places-plugin xfce4-quicklauncher-plugin xfce4-sensors-plugin xfce4-terminal xfce4-timer-plugin xfce4-verve-plugin xfce4-weather-plugin xfdesktop4 xubuntu-core xubuntu-desktop. It seems I need at least some of them. – 4xy Feb 16 at 20:40
  • Didn't work for me: Package 'exo-utils' is not installed, so not removed – snark Apr 17 at 20:01
0

You can update your default application for opening folders to nautilus by running the following command.

xdg-mime default nautilus.desktop inode/directory application/x-gnome-saved-search

H/T https://askubuntu.com/a/288136/628573

0

I went into my settings, selected Universal Settings, and at the bottom changed my Double-Click delay back to the original delay speed. It was the only solution to work for me. I was having the same problem, but running version 18.04. seen here

I hope this helps others!

0

Reinstalling nautilus did not resolve the issue. I tried many other things like resetting dconf and reinstalling gnome-tweak-tool etc but nothing helped. In my case, the issue was due to FileManager dbus service residue from another desktop which I assume might be interfering with the default desktop.

Steps to fix this issue:

# 1. Look for the residue:
cd /usr/share/dbus-1/services
ls | grep File

# 2. you will get something like:
org.freedesktop.FileManager1.service
org.gnome.FileRoller.ArchiveManager1.service
org.gnome.FileRoller.service
org.mate.freedesktop.FileManager1.service

# 3. delete the unused file manager service
sudo rm -f org.mate.freedesktop.FileManager1.service

To know whether you have the same issue you can:
1. terminate nautilus-desktop run it again in the terminal. (this way you can see logs from the nautilus service) 2. Try to open any folder present on your desktop and look for the error : cannot open folder on desktop, freedesktop bus not ready
3. If you see this its exactly the same issue and can be resolved by the above mentioned steps to fix.

Issue: error: cannot open folder on desktop, freedesktop bus not ready
Source: https://gitlab.gnome.org/GNOME/nautilus/issues/872

  • Thank you so much for me it started to work after removing all FileManager1 and then opening directory on desktop with right click and Open with – Boris Treukhov Aug 12 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.