-1

I have searched far and wide and looked at so many forum threads, but I'm still stuck with the same problem.

I'm running a Ubuntu 16.04.3 guest with VirtualBox 5.2.0 on a Windows 10 host.

I've installed Guest Additions 5.2.1 (which came with the VirtuaBox install) on the Ubuntu guest.

I set up a shared folder, making sure it's not selected as read only, have it auto-mount, and add myself to the vboxsf group. I also confirmed this by double checking etc/group.

I can create, copy, rename, delete files and folders in the shared folder, but I can't edit files.

ls -ld produces drwxrwx--- 1 root vboxsf 0 Dec 7 12:35 .. All files and folders within the shared folder have the exact same rights, owner and group. An example of a file a can't edit looks like -rwxrwx--- 1 root vboxsf 761804 Dec 6 15:19 objtest.txt.

I am unable to change the owner with chown, nor the permissions with chmod.

Update 1 - As suggested, no amount of restarts of the Ubuntu guest seems to solve the problem.

Update 2 - I've tried touch -a on a file with success, so it seems I can change meta data, just not file contents.

Update 3 - I've tried VirtualBox and Guest Additions v5.2.2 with no luck, I've tried installing Guest Additions with various methods of apt-get with no luck. Drag and drop doesn't work from Windows host to Ubuntu guest, even with the administrator trick, so I'm using a combination of things to get stuff working in a non optimal way. If any help comes along, I'll still be super thankful!

Update 4 - Played with rights on Windows side, removing all inherited permissions, making sure that Authenticated Users, Me, Users, Everyone have full control access - and no luck.

This is driving me up the walls. Everything suggests it's supposed to work. Everyone shouts "Eureka!" when they find out they have to add themselves to the vboxsf group, but still I am experiencing this weird problem. Any suggestions would be greatly appreciated. Perhaps it's something stupid this Ubuntu noob is missing.

  • 1
    Did you build the required modules in the Guest OS? – George Udosen Dec 7 '17 at 13:47
  • I'm going to guess no. What modules am I supposed to build to save a file? edit - by guessing no, I mean that I have not explicitly built anything intentionally, to my knowledge. :D – kowalski5233 Dec 7 '17 at 14:06
  • Launch the VM then from menu (top) select devices --> Insert Guest Additions CD Image, a window will show click run then restart your system – George Udosen Dec 7 '17 at 14:09
  • Oh, yes, this I've done. That's what I meant with "I've installed Guest Additions 5.2.1 which came with the VirtuaBox install.", but realise now that that is very ambiguous. I'm going to rephrase that quickly. – kowalski5233 Dec 7 '17 at 14:12
  • 1
    Haha, ok, thanks. I've restarted a number of times during this effort, but I'll definitely try a few more then. It doesn't sound right that I can create files, but not edit. Might very well be case of jealousy from Windows' side. – kowalski5233 Dec 7 '17 at 14:22

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.