I'm running Ubuntu mate 16.04.3 LTS (kernel 4.10.1) on my Thinkpad T470 laptop but I get some issue with ACPI.

The issue that I get is that at startup (not on all startup, only sometimes...) startup is hanging for about 20 secs with the following kernel traces

[    0.236026] ACPI : EC: EC started
[    0.236031] ACPI : EC: interrupt blocked
[    0.238872] ACPI: \: Used as first EC
[    0.238878] ACPI: \: GPE=0x16, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.238883] ACPI: \: Used as boot ECDT EC to handle transactions
[    0.241682] ACPI: Executed 26 blocks of module-level executable AML code
[    0.256270] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[   19.106645] ACPI: Dynamic OEM Table Load:
[   19.106801] ACPI: SSDT 0xFFFF969DEBBE3800 0006F6 (v02 PmRef  Cpu0Ist  00003000 INTL 20160527)
[   19.107232] ACPI: Executed 1 blocks of module-level executable AML code
[   19.107483] ACPI: \_PR_.CPU0: _OSC native thermal LVT Acked
[   19.110292] ACPI: Dynamic OEM Table Load:
[   19.110328] ACPI: SSDT 0xFFFF969DEB556000 0003FF (v02 PmRef  Cpu0Cst  00003001 INTL 20160527)
[   19.110699] ACPI: Executed 1 blocks of module-level executable AML code
[   19.111222] ACPI: Dynamic OEM Table Load:

Note time jumping from 0 to 19 seconds and also the following message:

[Firmware Bug]: BIOS _OSI(Linux) query ignored

After that, everything boots up with no problem and my system is up and running. All hardware functionalities, such as changing brightness, are working fine.

The problem is when I'm trying to shutdown the laptop, I'm getting a black screen and the laptop does not turn off. I have to keep pushing the poweron button for several second to have my laptop completely shutdown.

This issue is only happening whenever the laptop has hanged for 20 secs at startup and the kernel message has appeared. Whenever I do not have that kernel trace, the laptop shutdown gracefully.

I've already Google a bit a tried the following boot options but non of them worked for me

  • acpi=force
  • acpi=linux
  • acpi_os=Windows

Note that I do not want to disable ACPI (acpi=off) because otherwise I have to old the power button to shutdown my laptop anyway.

Does anybody has an idea what the problem could be?


I found the fix for my problem. I'm posting it here in case of other people encounter the same issue.

I updated the BIOS of my laptop to the latest version and the problem was gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.