7

Windows 10 + UBUNTU 17.10 dualboot on HP Envy x360 u000.

After installation, I am not able to make any changes in BIOS. The settings are not "Default". Secure boot is disabled.

I have tried the following things:

  • Wipe my HDD and tried to install Windows 10 again - Windows could not update the computer’s boot configuration. Installation cannot proceed
  • Tried to install UBUNTU - [ 0:000000] [Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x52 (or later)
  • Also tried to boot UBUNTU live - same error as above.
  • Tried to update/reinstall the HP BIOS firmware with HP BIOS Recover USB - Error code : 4(0x00000004). I tried both the ways. from windows and with bootable USB. got the same error
  • Removed battery and hold the power off button for 1 min. No luck.

Now I am totally stuck here.

I had my old HDD with windows 8 on it and I upgraded with a new SSD but I haven't done anything with my old HDD. So now I am using my laptop with that HDD. To boot windows I am doing manually EFI boot. Still not able to repair the bootloader on that too.

Update 1 (12-7-2017)

So, I am able to boot from UBUNTU 16.04 live USB

  • Tried to repair with Boot-Repair - No luck
  • Tried to remove/delete bootloader entry with efibootmgr but I can't do anything. every time I got this error Permission denied

    • sudo efibootmgr -v gives all the details of my SSD (volume ID and all), which I have used to install UBUNTU 17.10 where all the problems occurred in the first place. I am getting the same output even if I removed all the Drives from the motherboard.

So, everything written into BIOS is write protected. I am not able to do anything about that.

  • 5
    Bug #1734147 "Ubuntu 17.10 corrupting BIOS - many LENOVO laptops models"? – AlexP Dec 7 '17 at 11:05
  • Now this is confirmed that Intel SPI kernel driver is somehow affected by Ubuntu 17.10 They have disabled the download link because of this issue. – Prasanna Gajera Dec 21 '17 at 20:23
  • @AlexP this is a HP laptop, not a Lenovo. – TheUbuntuMaster Dec 23 '17 at 20:30
  • 1
    @TheUbuntuMaster: It appears that the problem is not with Lenovo as such but with a certain make of firmware, used mostly by Lenovo but also by some models of HP and Acer laptops. – AlexP Dec 23 '17 at 21:18
  • I was able to get my bios back and working based on the above instructions, on Lenovo Y50-70. I installed the proposed kernel 4.14.9, booted the computer with that kernel, then rebooted into the last ubuntu kernel and removed the 4.14.9 kernel. From that point my bios behaved normally. best, fixit – fixit Dec 28 '17 at 9:34
10

FINALLY, I GOT IT DONE!

I update the kernel to '4.14.9' and then restarted with ubuntu advanced options> with the latest kernel. and then restarted again. ALL BACK TO NORMAL.

This is what I did step by step

  1. Install Ukuu

    Its easy to update the kernel with Ubuntu Kernel Update Utility (Ukuu), Click here.

    sudo apt-add-repository -y ppa:teejee2008/ppa
    sudo apt-get update
    sudo apt-get install ukuu
    
  2. Update the kernel

    Select the kernel 4.14.9 and select Install. wait for the installation to be completed and then restart the PC.

  3. Restart the system with the latest kernel

    From GRUB select the option which starts with "Advanced options".

    Select Ubuntu GNU/Linux, with Linux 4.14.9-generic. wait for the system to load completely.

  4. Restart again and go into the BIOS

Restart the system again and check the BIOS to see if the problem is fixed.

I can change settings from BIOS. BIOS is detecting new HDD. In short everything worked out.

  • As I've noted elsewhere, Ukuu isn't perfect. It installs a kernel that will displace the managed, Apt-updated Kernel and so you'll have to keep using Ukuu (potentially finding new issues). The kernels it uses also don't have Ubuntu patches applied. They're raw upstream. I'm not saying this isn't worthy to get a working system, just be aware it's not a deploy-and-forget solution. Have a plan to roll it back when you can. – Oli Dec 27 '17 at 19:55
  • @Oli do you know if regular ubuntu kernel images are bootable after installing ukuu? As far as I know kernel 4.13.0-21 already fixes the problem and is available in ubuntu reps. So installing ukuu and updating the kernel to 4.14.9 and rebooting would, in theory, fix the BIOS and then going back to the last kernel in ubuntu reps should work. I am myself in doubt to install ubuntu 17.10 now in my new laptop, or await until the fix is published in the iso from canonical. – Andrés Alcarraz Dec 29 '17 at 0:01
  • Installing Ukuu (and a kernel package within it) won't remove the standard kernels from Ubuntu but the bootloader will preference the Ukuu ones because they have a higher version number. If an update has fixed this, just removing the Ukuu-installed ones (from within Ukuu) will fix this. Removing Ukuu (the application itself) alone will not. – Oli Dec 31 '17 at 14:07

protected by Community Dec 28 '17 at 12:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.