1

I am playing a youtube video in Chrome and switched to full screen and it works fine but when I press the volume button on my keyboard to adjust the volume, I see that xfce4-panel appearing all of sudden even in full screen mode. I tried using wmctrl -r "xfce4-panel" -b add,below and it is working. But when I place the command on startup, it is not working. I have to manually every time enter this command in the Terminal for the effect. I have also tried using sleep 20 && wmctrl -r "xfce4-panel" -b add,below command in the Session and Startup of Xfce with the view that the command will start after the xfce4-panel is loaded, but still it is of no use.

P.S: This happens even with VLC and other apps fullscreen mode also. When I try to make a screenshot of this to post here, I see that the panel is disappearing in the screenshot.

1

I wrote it in a shell file rather than directly pasting the command in the Session and startup like this.

#/bin/bash
sleep 10
wmctrl -r "xfce4-panel" -b add,below

and then added it to startup as "/home/user/wmctrl.sh" and it worked. The sleep 10 waits for 10 sec so that the xfce4-panel is loaded. Some systems may take longer, so the sleep value must be adjusted accordingly. I suppose that 10 sec would be optimal for most systems since it will not take more than that for xfce4-panel to be loaded after logging in and also, typically no one would play a video and go full screen and adjust volume within 10 sec of system startup.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.