I'm trying to get a functional Ubuntu instance running in VirtualBox on my iMac 27". The iMac has a resolution of 2560x1440, and I'd like to run Ubuntu in full screen at that resolution.

I've installed the Guest Additions that come with VirtualBox (rather than the ones in the archive). I'm using Ubuntu 11.10 64 bit.

The display currently runs at 1600x1200, and when I run the displays dialog (or xrandr), I get a list of resolutions that are 1600x1200 or smaller, and are all at 4:3 aspect ratio (whereas the iMac monitor is 16:9).

The settings for the virtual machine have video memory set to 128MB. Whether I run the VM with or without 3D acceleration makes no difference to the available resolutions (although with 3D acceleration enabled, launched windows aren't visible – a different question perhaps).

I have a natty VirtualBox VM that does run at 2560x1440, so I know it's possible. However, I don't know how to achieve it.

Thanks, jml

5 Answers 5


Well this is embarrassing.

It turns out that all I needed to do was run in full screen mode and then Ubuntu will figure out the new resolution automatically. I could have sworn I tried that. Oh well.

Don't know how to "cancel" this question, I'm afraid.

  • well, sometimes the easiest solutions are hardest to find :]
    – Misery
    Jan 25, 2012 at 13:06
  • 2
    That didn't work for me at all. I went to Full Screen mode, and Ubuntu 10.04 just stayed at the same 800x600 resolution. I then went into Ubuntu's System > Preferences > Monitors and did all manner of changes and it still kept the same size.
    – Volomike
    Jan 13, 2013 at 15:01
  • Seems to be enabled only when you install the VirtualBox Guest Additions and, I'm not sure, 3D acceleration enabled. It's great! Apr 24, 2020 at 15:44

This question has already been answered, however, I'd like to share the following post worked for me, namely commands I used were:

xrandr --newmode "2560x1440_60.00" 311.83  2560 2744 3024 3488  1440 1441 1444 1490  -HSync +Vsync
xrandr --addmode Virtual1 2560x1440_60.00
  • This worked for me. But when I restart the resolution is gone and I have to re-add it ... Any fixes for that? May 25, 2017 at 15:31

I found increasing the Video Memory to 128MB in the Virtual Machine display settings worked for me.


I've never used VB on Mac, but on Windows it might be impossible sometimes to get a high resolution. In general:

  • 3D accelleration (as far as I was interested in it last time) was highly experimental and may not work correctly.

  • If acceleration doesn'yt work, operating system (or rather GNOME) might not show options for making the resolution too high (or rather too expensive in the meaning of performance)

These are the limiting factors. However You may (carefully) try to change settings: create xorg.conf.new file and there in the proper section set the resolution.

The second thing might be that Your hardware (monitor) is not recognized by Ubuntu. So looking up xorg.conf.new would give us the hint.


this may not be possible as i have found instances of 64 bit OS' under vbox to still be lacking comapred to 32 bit (i'm running 4.1.8) so it may be a current limitation of the 64 bit at this time , but maybe you can manually set the resolution in xrandr

you may want to refer to xrandr --help from a terminal

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.