23

I am using Ubuntu on a laptop which I put in a docking station with two screens.

The night light works well when activated but after unlocking from screen saver, only the main monitor is in night light, not both.

Anyone already had that problem and found a fix ?

Thanks in advance, Lionel

2
  • I actually wanted to do this on purpose, don't know how. May 19 '19 at 3:14
  • There is no official solution and it seems that nobody cares, neither gnome, nor xorg, nor nvidia nor canonical, this problem has not been solved for many years and everyone knows about the problem. Think that there is not even an option to manipulate the brightness of the screen in a desktop installation, even less are they going to solve a night light problem.
    – e-info128
    Feb 16 at 2:08
15

This is clearly a bug. This bug report is quite similar to yours; when it's addressed that will hopefully fix our problems as well.

A workaround is to go to the Devices → Color menu in the settings and toggling color management for the problematic monitor off and on.

3
  • Wow, well I feel sad to say that this bug is still happening on Ubuntu 18.04 to this day. And your trick fixed it indeed.
    – BraveKenny
    Jun 18 '18 at 20:09
  • I couldn't get it to work with the stated workaround. But switching my secondary monitor to my main and back in display settings fixed the problem. Though I don't know if it will last.
    – Adam
    Aug 7 '18 at 13:32
  • Seems this is still a problem (well over a year on), and unfortunately this workaround doesn't seem to work any more. :/
    – Larnu
    May 4 '19 at 21:55
10

In https://gitlab.gnome.org/GNOME/gnome-settings-daemon/issues/6 it is recommended to run killall gsd-color. While toggling color management on or off applied only the current value running kill works throughout the phases on both monitor correctly.

4
  • 1
    Dont work on ubuntu 20.04
    – e-info128
    Feb 20 at 7:45
  • @e-info128 Questions and answers have been posted in 2018. Things may have changed in 20.04 and Gnome under the hood and maybe you have a different problem which deserves its own question and answers. The bug was closed, and at the moment I cannot reproduce it on the installations I have. What ever problem you have, please report it upstream in a detailed and constructive manner. Should I experience the problem and find a better solution I will post it for sure. But uh, really what do you expect from me in particular? And to the one who down-voted, what did you accomplish?
    – LiveWireBT
    Feb 20 at 19:43
  • It should be said, that this kills your complete gnome session! Jul 27 at 18:56
  • @AndreasFlorath You are the first one to report this. Can you reproduce this? I can not.
    – LiveWireBT
    Jul 27 at 23:07
5

This seemed to work for me:

Ubuntu -> Screen Display -> Night Mode On

  1. On the working screen - set as Single Display with Night Mode ON.
    The other monitor should go blank
  2. Enable Mirror Display - Mirror should then show in Night Mode as well on the 2nd monitor
  3. Change to Join Displays - Ordering might be out
  4. Change the screens to the correct placement ...
2
  • First applying Mirror Display Mode and Night Light followed by reapplying Join Displays Display Mode worked. Thanks.
    – Sun Bear
    Oct 12 '20 at 15:00
  • 3
    Not work on ubuntu 20.04
    – e-info128
    Feb 20 at 7:46
1

For me what worked was to turn the second monitor as the primary, apply and then revert to first one as the primary monitor. This could be found here: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1757280

0

this is quite old topic but I seem to have the same issue, messing with NvidiaServer( If you have NVIDIA card ) turn off "Allow Flipping" seems to help

0

I had some issue. I had to untick Proprietary drivers, and now night mode is working on dual monitors.

enter image description here

0

It is quite simple in Ubuntu 20.04. Go to Settings → DisplaysNight Light and then turn on Night Light. It Works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.