0

I am setting up a 16.04 installation on an old Macbook pro with a Broadcom B4322 (14e4:432b).

As this hasn't worked out of the box I've tried installing other drivers:

  • bcmwl-kernel-source
  • firmware-b43-installer
  • broadcom-sta-common

Installing these packages had no effect.

$ sudo lshw -c network

  *-network               
       description: Network controller
       product: BCM4322 802.11a/b/g/n Wireless LAN Controller
       vendor: Broadcom Limited
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:17 memory:d3200000-d3203fff   *-network
       description: Ethernet interface
       product: NetXtreme BCM5764M Gigabit Ethernet PCIe
       vendor: Broadcom Limited
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 10
       serial: 10:9a:dd:4a:d0:63
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.137 firmware=5764m-v3.38 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:27 memory:d3100000-d310ffff   *-network
       description: Wireless interface
       physical id: 2
       logical name: wlan0
       serial: f0:b4:79:1c:0d:71
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43 driverversion=4.10.0-40-generic firmware=666.2 link=no multicast=yes wireless=IEEE 802.11



$rfkill list all 0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no 1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Can anybody help me?

  • 1
    edit: rather, make sure you have firmware-b43-installer installed because from googling it's the firmware your card should work with, then reboot, then post the output of sudo lshw -c network. – Hi-Angel Dec 6 '17 at 16:25
  • 1
    And also: rfkill list all – chili555 Dec 6 '17 at 16:38
  • Thank you for your comments. I've just added to the question the results of the commands you have asked for. – pedrorolo Dec 6 '17 at 16:57
0

I've just discovered that bcmwl-kernel-source works after having suspended the the system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.