1

I am using an Dell Latitude 3480 laptop which comes with the Qualcomm Atheros QCA6174 Wifi card with Ubuntu OS (16.04 Release). When I use it as a sniffer (using wireshark) after enabling monitor mode using airmon-ng, I am only able to get Beacon and Probe response frames (which are the management packets).

I am not able to get the data packets in wireshark.

I tried sniffing packets from an tcp traffic run between an Netgear AP and a client in 5G network with open-none security.

Is this an expected problem with this card?

I tried reinstalling the driver and all, but no change. The kernel I use is 4.4.102-0404102-generic.

Can someone really help me out?

0

Do you use custom drivers? As far as I know linux distros that are capable of sniffing wifi have custom drivers installed, like Kali, Backbox and so on. I don't think there is a problem with the card itself, but rather with the software.

I suggest you try using Kali or other distros and use tools like airodump-ng, so you can rule this out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.