11

Installed a bunch of updates to my Ubuntu 17.10 desktop tonight, and rebooted. Now the media keys at the top of my DELL USB keyboard no longer work.

When I run sudo showkey it looks like the volume knob, play, stop, calculator, etc..., are still sending key down and key up events. But those don't seem to do anything anymore, as if Ubuntu is ignoring all the extra keys. Anyone have ideas?

sudo showkey
...
keycode 140 press # calculator
keycode 140 release
keycode 113 press # mute
keycode 113 release
keycode 166 press # stop
keycode 166 release
keycode 114 press # volume down
keycode 114 release
keycode 115 press # volume up
keycode 115 release

sudo lsusb
...
Bus 001 Device 004: ID 413c:2010 Dell Computer Corp. Keyboard
Bus 001 Device 002: ID 413c:1003 Dell Computer Corp. Keyboard Hub

2 Answers 2

25

I had a similar problem with the media keys (mute, play, pause) after installing the Unity interface on a clean 17.10 installation. The media keys worked fine in the login screen and on the Gnome interface desktop.

The post How to find *why* I can't bind some keyboard shortcut (or which app took it)? gave me an insight for a workaround. It seems to be some issue with compiz.

I installed Compiz Config Settings Manager

sudo apt install compizconfig-settings-manager
ccsm

and disabled the plugin Commands. After that the media keys seem to be working fine.

8
  • 3
    sudo apt-get install compizconfig-settings-manager followed by ccsm. Disabled the Commands plugin just like you wrote, and now my media keys work again. Thanks!
    – Stéphane
    Dec 7, 2017 at 6:06
  • 4
    Didn't help me.
    – Suor
    Jan 5, 2018 at 14:53
  • 5
    Didn't help me too.
    – Ezio Somà
    Jan 30, 2018 at 21:54
  • 1
    works on 18.04 too
    – Saulius M
    Mar 2, 2018 at 18:58
  • 5
    Same issue on 18.04. Media keys wont work, even after disabling commands. Can someone help Apr 15, 2018 at 11:27
0

On Ubuntu 18.04 with Unity installed, this answer worked for me:

cd && mv .gconf .gconf.old

EDIT:

Subsequent Fix 1: Strangely, a couple weeks later, the problem came back, and while the accepted answer (disabling the "Commands" plugin) hadn't worked the first time, this time it did. Not sure that plugin got re-enabled.

Subsequent Fix 2: 19 days after the above fix, the problem returned. Toggling "Commands" plugin off and on fixed it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.