Could someone help me with getting hibernate to work? I reinstalled my hard drive due to a corrupt update from Mate 16.04 to 17.10 making a shit ton of duplicate files on there, and now I can't get hibernation to work anymore.

Tried running sysctl hibernate in terminal, acts like normal shutdown (I think because of swapspace not being activated). My fstab shows something weird though, a cryptswap? I'll add a screenshot. Also I get an error after doing swapon, and I have no idea why it happens.

partition scheme

fstabcontents

swapon error

Did I screw something up?

Please do ask if you need more info.

Edit1: The hibernation guide on help.ubuntu.com states that you need use sudo systemctl hibernate, and as so this command made hibernation fail for me and act like a generic shutdown I thought I did something wrong, even though hibernation worked in the past. Yesterday I was tinkering with hibernation again (without the guide) and my memory made me use sudo pm-hibernate instead of what was given in the guide. Now that I'm sure I did not screw up, and using hibernation as usual again.

Sorry for the late edit but this question is solved.

The guide on help.ubuntu.com might need an update? Just a suggestion, I know that I don't know much about Linux, maybe this is just a fix for me and not for a lot of others.

  • When you run free -h what do you see? – George Udosen Dec 6 '17 at 1:52
  • Edited, sorry for late reaction. free -h gave me that swap partition should've worked properly though. The edited part explains further. – Spurkl3z Dec 10 '17 at 22:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.