2

Due to my nvidia GPU and my favourite terminal not currently supporting Wayland I need to use Xorg as the server.

During login, selecting the gear relating to GNOME with Xorg (after installing 17.10 I switched to the vanilla GNOME interface) gives me a black flashing screen and I am then ejected back to the login screen. Can anyone provied some insight as to what I need to do to resolve this?

I am able to login through openbox and echo $XDG_SESSION_TYPE gives me x11 so I know Xorg is present. I have run the Ubuntu repair utility that comes with the installer.

I have set WaylandEnable=false in /etc/gdm3/custom.conf to false and that lets the login screen run Xorg however the flashing black screen issue persists.

This is my last faile login from /var/log/auth.log using ubuntu gnome:

Dec  5 18:37:37 micks-MS-7A33 gdm-password]: pam_unix(gdm-password:session): session opened for user micks by micks(uid=0)
Dec  5 18:37:37 micks-MS-7A33 systemd-logind[886]: New session 6 of user micks.
Dec  5 18:37:37 micks-MS-7A33 dbus[869]: [system] Rejected send message, 2 matched rules; type="error", sender=":1.2" (uid=0 pid=886 comm="/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" d
estination=":1.177" (uid=1000 pid=2861 comm="/usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/use")
Dec  5 18:37:38 micks-MS-7A33 dbus[869]: [system] Rejected send message, 2 matched rules; type="error", sender=":1.2" (uid=0 pid=886 comm="/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" d
estination=":1.177" (uid=1000 pid=2861 comm="/usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/use")
Dec  5 18:37:38 micks-MS-7A33 dbus[869]: [system] Rejected send message, 2 matched rules; type="error", sender=":1.2" (uid=0 pid=886 comm="/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" d
estination=":1.177" (uid=1000 pid=2861 comm="/usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/use")
Dec  5 18:37:38 micks-MS-7A33 dbus[869]: [system] Rejected send message, 2 matched rules; type="error", sender=":1.2" (uid=0 pid=886 comm="/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" d
estination=":1.177" (uid=1000 pid=2861 comm="/usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/use")
Dec  5 18:37:38 micks-MS-7A33 dbus[869]: [system] Rejected send message, 2 matched rules; type="error", sender=":1.2" (uid=0 pid=886 comm="/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" d
estination=":1.177" (uid=1000 pid=2861 comm="/usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/use")
Dec  5 18:37:38 micks-MS-7A33 dbus[869]: [system] Rejected send message, 2 matched rules; type="error", sender=":1.2" (uid=0 pid=886 comm="/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" d
estination=":1.177" (uid=1000 pid=2861 comm="/usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/use")
Dec  5 18:37:38 micks-MS-7A33 dbus[869]: [system] Rejected send message, 2 matched rules; type="error", sender=":1.2" (uid=0 pid=886 comm="/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" d
estination=":1.177" (uid=1000 pid=2861 comm="/usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/use")

edit: putting WaylandEnable=false back as a comment block still gets me

Dec  5 19:13:48 micks-MS-7A33 dbus[877]: message repeated 17 times: [ [system] Rejected send message, 2 matched rules; type="error", 
sender=":1.0" (uid=0 pid=833 comm="/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus
.Error.UnknownMethod" requested_reply="0" destination=":1.147" (uid=1000 pid=4369 comm="/usr/bin/gnome-shell ")]

so org.freedesktop.DBus.Error.UnknownMethod is still the issue

0

Setting WaylandEnable to false isn't required to run a session on X.org. I would suggest commenting that line in your config, rebooting, and trying to log into GNOME on Xorg again.

edit: I should add that changing this setting in my own gdm3 config resulted in a similar login issue and reverting the changes I made resolved it.

4
  • commemnting that back out and restarting still gets me Dec 5 19:13:48 micks-MS-7A33 dbus[877]: message repeated 17 times: [ [system] Rejected send message, 2 matched rules; type="error", sender=":1.0" (uid=0 pid=833 comm="/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus .Error.UnknownMethod" requested_reply="0" destination=":1.147" (uid=1000 pid=4369 comm="/usr/bin/gnome-shell ")] so org.freedesktop.DBus.Error.UnknownMethod is still the issue – Micks Ketches Dec 6 '17 at 1:17
  • Have you tried reinstalling gnome shell and wiping all configs with sudo apt-get purge gnome-shell && sudo apt-get install gnome-shell? You could also check your startup applications through another DE, but I doubt the cause would be there. – user444482 Dec 6 '17 at 1:22
  • 1
    gnome wont launch at all now lol, get ` /dev/sda1: clean` and a black screen, trying to troubleshoot through grub... – Micks Ketches Dec 6 '17 at 1:52
  • Perhaps gdm3 was removed somehow? Try installing it again from the GRUB command line – user444482 Dec 6 '17 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.