I have problems with camera on my Lenovo G510 with Ubuntu 16.04.

Camera used to work before, but it stopped working.

I installed Skype and tried to make a call. At the first try camera was working but microphone didn't work. I restarted the laptop, tried to play around changing settings in All Settings> Sound. The microphone stated working. But this time camera didn't work.

I tried to update software via apt-get (update>upgrade>dist-upgrade), but it didn't help. Restart didn't help as well.

I didn't try the commands offered in this question because I don't understand what they do. And since camera used to work before I guess I don't need to install any additional software.

Note: The problem not only with Skype, Cheese says "No device found".

I also receive some crash reports after each restart (or just spontaneously). There is some failed python script. But I'm not sure how this relates to the camera setup.

Here is my lsusb output (if it could be helpful)

Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 003 Device 002: ID 09da:054f A4Tech Co., Ltd. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


After few more restarts camera started working somehow. But the problem is not solved (I can't guarantee that it will work tomorrow).


You must log in to answer this question.

Browse other questions tagged .