i have just very fresh install of 11.10 64bit on my 3Ghz dual core machine. Graphic card nvidia 9600gt with the 290.10 driver. Desktop crashes or will be not redraw correctly. Its very instable with using skype or log file viewer and other applications. I get massiv error outputs in xsession-error log related to gdk or glib. I was using ubuntu 10.04 64bit without any problenms long time, i was also using the same graphic driver without any problems and compiz was running successful. This is an example of such error output from just a few minuts using desktop after reboot:xsession-errors log Is it possible to fix it? Also cpu usage is so much higer as before. What if want to start 3d rendering? Or my other cpu intensiv applications? How should i make it with such a values? I have now just skype and google-chrome and log viewer on and CPU usage is 50%. I feel bad. Regards

so slowly i dont know what to think. So how you suggest i made again new fresh installation. Now i didnt take the newest nvidia driver but this one from the repository 280.13. CPU values seams to be normal now but look please on the output of xsession-errors:link. My system is 2 min old up to date, no ppa in the packadge management. absolutly clean. i am runing just firefox + log viewer.Just btw. it was 7th installation of this system. I dont get it to normal state. Why? My graphic card is supported. I was runing this card on the newest driver already and made fantastic 3d renderings on it. What can i do else as to take onother distro? Is it possible to fix this problem? I dont want to give up ubuntu. It was long long time my favorit system. My graphic driver is not loaded:enter link description here Why?

BTW. also i cant give comments here on askubuntu...I was forced to make answar on my own quastion

4 Answers 4


check your software sources to see if you have proposed enabled if not enable it

then do ctl-alt-F1 login and do sudo apt-get update && sudo apt-get dist-upgrade when its finished to sudo apt-get remove nvidia-current* then sudo apt-get install nvidia-current

i had this happen to me on a new install and it worked for me! if this doesn't help add the ppa:xorg-edgers/ppa and do sudo apt-get update && sudo apt-get dist-upgrade

  • great, this was a nice tip. Thank you very much. My driver is now loaded! But the glib errors are not gone link Also recovery mode menu is not drawing in the right way...so is hard for me to choose right menu point.
    – user43484
    Jan 26, 2012 at 19:19
  • just out of curiosity when you did the update and dist-upgrade did the update install a new kernel? if it did you may have to repeat the process with that kernel: is dkms installed? or perhaps download a fresh iso of ubuntu perhaps the one you used was corrupt! like denNorske wrote.
    – bmbaker
    Jan 28, 2012 at 19:54

Have you tried to run this from tty: (press CTRL + ALT + F1 or F2 or F3)

Compiz --replace

(if it is Compiz u have as default screen manager?)

unity --replace

(if it is unity as default)

cause it can maybe be the problem..

  • i am using unity, isnt compiz based?
    – user43484
    Jan 25, 2012 at 11:24
  • so i made unity --replace from tty. I ve got a lot of errors. Some of them here: glib.glib - gobject <unknown>: = invalis (NULL) pointer instance; compiz(shift)- no compatible text plugin loaded; unity-panel-service: no prcess found; compiz(unity)-Warn: unsupported internal format, segmentation fault. I could just reboot after that. Now is just web browser open - CPU usage 60%
    – user43484
    Jan 25, 2012 at 11:42
  • pls look at the xseassion-erross log after reboot: pasteall.org/28514
    – user43484
    Jan 25, 2012 at 11:59
  • also i discover some strange thing. the comsole putpu of inxi about my system discover that my new driver is not loaded:Graphics: Card: nVidia G94 [GeForce 9600 GT] X.Org 1.10.4 drivers nvidia unloaded: nouveau,vesa,fbdev Resolution 1920x1080@50.0hz but in nvidia setting control i see that driver. What about?
    – user43484
    Jan 25, 2012 at 12:01

When you are in Grub at the boot stage, navigate down to recovery-mode, and try to fix it from there . I will strongly reccommend you to do a fresh, new install. Once more :S the install looks corrupt to me. Are you sure the graphics card s supported? do a research :)

  • my graphiccard is DEFINITLY supported. but something is wrong with loading of the driver: "Graphics: Card: nVidia G94 [GeForce 9600 GT] X.Org 1.10.4 drivers nvidia unloaded: nouveau,vesa,fbdev Resolution 1920x1080@50.0hz" and in the nvidia control settings the driver 290.10 is enabled.
    – user43484
    Jan 25, 2012 at 12:40

i have solved my problem this way and only this one was working for me as this:

  • I made fresh install of ubuntu
  • after system update, I did not install any proprietary graphic driver from the repos, I left just this one which is open source: 173.*. which ubuntu installs automatically.
  • I have enabled proposed (pre-released) updates in synaptic and add this ppa to the repository: http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu
  • then i made sudo apt-get update && sudo apt-get dist-upgrade
  • sudo apt-get install nvidia-current
  • reboot

The problem with other instruction was that the newest kernel didnt work with 280.10 nvidia drivier on my computer and i have got missmatch API or the machine didnt boot or i had massiv errors in xsession-erros log and CPU disaster.

I want to remain, that the glib errors still apear in the logs but no that much as before, the computer runs wonderful, very fast and stable now and some of the errors will gone after installation of some packets and little tune there and there..the rest is just not important i guess.. Regards to all helpers. have a a nice day! (Something must be done to kernel updates + Nvidia updates)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.