1

Not sure what's going on here. Sometimes when I boot up my (color theme?) is blue instead of the default orange. Other times its the normal orange.

enter image description here

enter image description here

I hate the orange and would like to make it always be blue and would also like to make my laptop always blue as well. Also my login screen on my desktop is still the old login screen and my laptop is the new one. No clue whats going on with my desktop and I can't get it figured out. I have no shell themes installed.

Ubuntu 17.10
GNOME Shell: 3.26.1


Current settings in tweaks/Appearance
Applications: Adwaita-dark
Cursor: DMZ-White
Icons: Ubuntu-mono-dark
Shell: (None) Default

1

It seems you're (inadvertently) switching between the (vanilla) "GNOME" session and the modified GNOME session titled "Ubuntu" ("Ubuntu" is orange, "GNOME" is blue).

You may load the "bluish" GNOME shell theme from your home directory. To do that follow the steps below.

  1. Create a directory, say MyTheme either in ~/.themes or in ~/.local/share/themes. (You may create ~/.themes or ~/.local/share/themes if they don't exist.)
  2. Create another directory inside MyTheme called gnome-shell.
  3. Create an empty document in this gnome-shell directory and name it gnome-shell.css.
  4. Open this gnome-shell.css in a text editor and add the following line

    @import url("/usr/share/gnome-shell/theme/gnome-shell.css");  
    
  5. Install and activate the User themes extension from here.

  6. Launch Tweaks, go to Appearance section and click on the drop-down box next to "Shell theme". MyTheme should appear in the drop-down list. Select it.

  • Switching from GNOME session to Ubuntu session from the lock screen does not change the colors at all on my desktop or laptop. Desktop stuck with the blue theme. Laptop stuck with the orange theme. Also why is my desktop stuck with the old login screen? – Blake Dec 5 '17 at 19:49
  • @Blake Not sure why this is happening, but you should be able to manually set the "blue" theme following the steps in my answer (make sure you have the gnome-shell.css file in /usr/share/gnome-shell/theme/ first). Similarly you can manually set the "orange" theme too. – pomsky Dec 5 '17 at 21:12
-2

I am new to Ubuntu... Reseting Gnome shell may help. Type the command below

dconf reset -f /org/gnome/

you would need to re-configure your UI settings. At your own risk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.