I just updated my z270x Intel (Gigabyte) Motherboard. I upped the BIOS from F6 to F7, fixing a hyperthreading fault. Afterwards, my wifi chip didn't work.

There has been some discussion on the Arch Linux Forum that claims you have to turn off the PC completely for a sufficient amount of time so the card can completely shut off and reconfigure itself for the new BIOS.

That doesn't work for me however (5min wait without power cord attached and pushing power button a few times)

Odd is, the bluetooth (which is on the same adapter) works.

  • 1
    What has this to do with Ubuntu ? – Soren A Dec 5 '17 at 12:27
  • it happened on Ubuntu but dual booting to Windows, the Wifi worked. I guess I didn't mention that, sorry. To be fair I guess it could also be not Ubuntu specific but Linux related, but would this mean not to post this question and then, where would the right place be? – pascalwhoop Dec 5 '17 at 20:43

What did help me in the end was placing the PCI adapter into a different slot. It might be, that this finally allowed the card to discharge or it could have some other effect OS. But placing it from PCI slot 1 to 6 solved it for me.

So: BIOS Upgrade? Move the Wifi Adapter a bit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.