0

I Have a TP LINK TL-WN722N wireless usb adapter. I have to use it because all onboard wifi chips never work. Here is the wireless info script: https://pastebin.com/q7eFC5Fm

What happens is my adapter status becomes disconnected and asks repeatedly for my wifi password. I cannot stop this process until I unplug the adapter and plug it back in.

Paste for dmesg command: https://pastebin.com/VykRHHhf

  • Use only WPA2-AES. – user692175 Dec 5 '17 at 11:38
0

I have an Intel wireless device and a TP-Link TL-WN722N and the Intel works much better. I am going to recommend some changes to you and I suspect that, if you undertake all of them, the internal Intel device will work very well.

First, turn off power saving in Network Manager. From the terminal:

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*

Next, I recommend another change to Network Manager.

 sudo nano /etc/NetworkManager/NetworkManager.conf

Edit the file so that it now reads:

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[device]
wifi.scan-rand-mac-address=no

After making any needed changes, save the file (Ctrl+o followed by Enter) and exit nano (Ctrl+x).

Reboot the computer.

Next, as has been noted, many Linux drivers, including ath9k_htc and including iwlwifi hate hate hate TKIP.

Please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

After all these changes, is there any improvement?

  • I don't have a NetworkManager.conf file or directory. In it there is only dispatcher.d, dnsmasq.d, system-connections, VPN (folders), NetworkManger.conf (file) In NetworkManager.conf: [main] plugins=ifupdown,keyfile,ofono dns=dnsmasq [ifupdown] managed=false – Jinzu Dec 5 '17 at 16:00
  • I don’t understand. You say you don’t have the file and then tell me you do have the file and what’s in it. Please add the [device] stanza as I suggested. – chili555 Dec 6 '17 at 3:40
  • My mistake I meant to say I do not have the conf.d directory. When I run your command I get this: "sed: can't read /etc/NetworkManager/conf.d/*: No such file or directory" – Jinzu Dec 6 '17 at 4:16
  • I see now that you are running 14.04. Please skip the power saving step and move forward with all the other steps. – chili555 Dec 6 '17 at 14:29
  • Is there anything else that can be done? it asked for authentication again. Is it because the wireless usb is faulty? – Jinzu Dec 9 '17 at 17:25
0

I also had the problem of continuous re-entering the correct WiFi password with an old ASUS Eee PC 900HA (AR2427 802.11bg Wireless Network Adapter (PCI-Express)) running Linux Lite 3.8.

The problem was that my wireless access point accepted only 802.11n, while the adapter only supports 802.11bg.

I solved this by logging in with another computer to the access point (in my case 192.168.0.1) with a browser, and changing the wireless network settings from 802.11n-only to mixed (802.11b/g/n). Note that this can also be done with a wired (ethernet cable) connection on the same computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.