0

How do I disable my Realtek wifi driver? It makes my laptop freeze when connected. To work around the problem, I got a USB wifi adapter. Problem is, the Realtek driver still connects to the network and I have to manually disconnect it. I tried to blacklist it, but I obviously didn't do it right. Here is a screenshot of my network connections (the Realtek and the wifi adaptor are both higlhlighted in yellow):

Screenshot

My specs are also listed here: http://paste.ubuntu.com/26050614/

I'm a newbie and confused!! Your help will be greatly appreciated on this one! Thanks!!

  • this is idea only (ie. a dirty a hack!). I'd use a command like lsmod to list your modules (to confirm its 'rtl819xE' as I saw in your listing); then unload the module to check it achieves what you want (eg. sudo rmmod rtl819xE); if it has no negative side-effects I'd probably just add it to the 'blacklist' so the kernel module isn't loaded on future reboots. this is messy but easily reverted (I'd add comments as to why I added it to blacklist). I'm assuming its not compiled into kernel (that is more work!), but refer askubuntu.com/questions/110341/how-to-blacklist-kernel-modules – guiverc Dec 5 '17 at 3:46
0

your laptop should have a button that disables wifi; its usually on its front or right sides; might be on top near the screen; it also might have a marked combination on keyboard.. look for an stylized antenna mark

also you can right click you network icon and edit(delete) the problematic wlan connection so it would not autoconnect

considering this article

https://linuxconfig.org/how-to-blacklist-a-module-on-ubuntu-debian-linux

as root

lsmod //lists the modules; search for something realtek related

modinfo -F depends [module name] //to see if it has modules that depend on it

nano /etc/modprobe.d/blacklist.conf

and add > blacklist [module name] //if it has other modules depending on it it will not be blocked

or add > install usbcore /bin/true //which will block the module and dependencies

save and exit nano

update-initramfs -u

reboot

  • The Shift + F8 command to turn off my Toshiba Satellite L500 wifi antenna does not work. Maybe that command is not compatible with Ubuntu 14.04? – Spartina Dec 6 '17 at 0:34
  • Additionally, I wasn't able to successfully delete the problematic wlan connection and prevent it from autoconnecting. – Spartina Dec 6 '17 at 0:36
  • try FN+F8 for function key – user688056 Dec 9 '17 at 22:33
  • Thanks, that was a typo on my part. The proper key combination is FN+F8 as you point out. – Spartina Dec 10 '17 at 16:28
0

The option to blacklist that driver is the right thing to have done, the other option would be to remove it but this should be a last resort after all else. I suggest you just blacklist and to blacklist that driver simple do:

echo "blacklist rtl8192se" >> /etc/modprobe.d/blacklist.conf

Then reboot and run: dmesg | grep 819 or lsmod | grep 819 to make sure its no more loading.

0

Thanks everybody for all your help. I just learned a whole bunch that I wasn't aware of by reading your posts.

The answer for me was to identify and blacklist the offending module which it turns out was r8192e_pci and not other ones I had previously added to the blacklist.conf file (the hardest part for me in the end was to properly identify the module that I didn't want loading).

Even though it has rtllib as a dependency, doing 'blacklist r8192e_pci' appears to be enough to stop it from loading.

I should add that post #14 from Chili555 also helped me figure things out. https://ubuntuforums.org/showthread.php?t=1826243&page=2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.