2

I am hoping to find a solution to this very annoying issue. I turned on my PC today and noticed that only my VGA monitor was detected, which is odd because just last night both monitors were working normal. The other issue is that the monitor that does work will only allow me to have 640 X 480 resolution.

Things I have tried:

  • Switching from Nvidia drivers to Xorg.

  • Purging and reinstalling Nvidia

  • Rebooting several times

  • Adding monitors in the terminal with Xrandr (When I do this it gives me "Failed to get size of gamma for output defaults")

Yesterday I was tinkering around a bit with Wine and PlayOnLinux, but I am not sure if that is what caused this issue. When I go to the monitor settings it only shows my VGA monitor, and will not let me change the resolution. I was originally allowed to change the resolutions of the HDMI and VGA monitors with no problem.

Let me know what other information I can provide to help fix this issue.

Following the advice of a commenter I tried dmsg | grep -i nvidia and got this output:

[    2.522071] nvidia: module license 'NVIDIA' taints kernel.
[    2.530529] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    2.537250] nvidia-nvlink: Nvlink Core is being initialized, major device number 247
[    2.537639] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  384.98  Thu Oct 26 15:16:01 PDT 2017 (using threaded interrupts)
[    2.539046] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  384.98  Thu Oct 26 14:41:13 PDT 2017
[    2.539722] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[   13.660397] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1/input5
[   13.660463] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1/input6
[   13.660530] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1/input7

After entering lspci -v | grep -i nvidia I get:

01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 640] (rev a1) (prog-if 00 [VGA controller]) Kernel driver in use: nvidia Kernel modules: nvidiafb, nouveau, nvidia_384_drm, nvidia_384 01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)

  • By coincidence I've been debugging nVidia this week. You could try dmesg | grep -i nvidia in the terminal. Perhaps include the output in your question if you dig up something interesting. More tedious you can search for errors in /var/log/syslog with your favourite editor. – WinEunuuchs2Unix Dec 5 '17 at 1:22
  • Thanks for your reply! I entered your command and added the output to my question. I am a noob so the messages do not mean much to be but I noticed a line said "module verification failed". Maybe that could mean something. – Matéo Amero Dec 5 '17 at 1:41
  • You're welcome. The tainted kernel error doesn't stop nVidia from working I get it on my system too. nVidia developers blame it on Nouveau I learned researching that error message. I notice you are missing a line I have in mine: [ 3.632485] nvidia-uvm: Loaded the UVM driver in 8 mode, major device number 243. Unfortunately I just started learning nVidia a couple weeks ago and don't know the impact. – WinEunuuchs2Unix Dec 5 '17 at 2:17
  • I have a similar UVM message as @WinEunuuchs2Unix. – Organic Marble Dec 5 '17 at 2:40
  • @OrganicMarble maybe it changes based on card? I have a GTX 970M. @Mateo can you include output from: lspci -v | grep -i nvidia? – WinEunuuchs2Unix Dec 5 '17 at 2:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.