0

I'm trying to access an RDP server using a German keyboard configuration. The keyboard works perfectly well on clients but not if used in a full screen RDP session: In that case the Alt+Gr-Key does not work. Which is pretty annoying as on German keyboard layouts pressing "<" and AltGr will result in a pipe symbol "|". If this does not work it means: You can not type pipe symbols. You can not type backslashes and you can not type ~

The keyboard has been configured as a generic 105 key keyboard on the client OS as well as the remote OS. Whatever I do, the AltGr key has no effect.

But: If I open the "keyboard layout" sheet on the remote machine via RDP I see the corresponding key displayed as black if AltGr is pressed. Which concludes: The key itself is sent to the remote host, but the remote OS does not convert this correctly to the corresponding key press.

Another "glitch": Sometimes if I start remmia the software falls back to English keyboard layout though German layout is (!) configured. In that case I have to remove the keyboard layout in Gnome on the remote machine and add it again. Then I can use most keys again as defined by the German layout - except AltGr.

This is quite annoying as you NEED ~, | and \ in your daily work. I can not provide RDP to regular users if their keyboard isn't working correctly. Does anyone know how to solve this problem? Thank you!

OSes used:

  • server: Ubuntu 17.10
  • client: Ubuntu 16.04

As requested here the output of /etc/default/keyboard:

Client:

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT="deadgraveacute"
XKBOPTIONS=""
BACKSPACE="guess"

Server:

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT=""
XKBOPTIONS=""
BACKSPACE="guess"

Update 1: After a relogin I encountered again EN settings for the keyboard. I - again - reconfigured the keyboard to DE and ... Suprise! It worked. Which concludes: This problem is correlated to RDP/remmia not keeping the settings that have been configured. So the question is: How can I make configured keyboard settings permanent and prevent RDP/remmia from changing them? :-/ Any help is appreciated!

Update 2: I figured out that tough the GUI keyboard tool of Ubuntu Mate displays the correctly configured keyboard settings - German (and only German) - while at the same time some kind of Gnome keyboard indicator applet displays "EN" as layout and offers only (!) English layout after a reconnect with remmia. The only way to resolve this discrepancy is to remove the keyboard settings completely in the Gnome dialog and add it again. Then everything works fine (but only as long as the current session lasts.) Has anyone a clue where the Gnome applet takes it's information from and why it differs from the data presented in the Gnome keyboard configuration dialog? (By the way: I'm using Mate as window manager.)

  • Can you please show the output from cat /etc/default/keyboard on both machines. – Gunnar Hjalmarsson Dec 5 '17 at 0:10
  • This problem seems to be related to a bug in xrdp which seems to exist for at least a single year. I'll update this question if I learn some details about this during the next days. – Regis May Dec 5 '17 at 8:40

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.