20

How to install Wi-Fi drivers in Ubuntu 16.04?

lspci -v | grep -i network
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device d723 
  • We need more hardware information to help you, can you look at this question and then edit your question adding the information. – J. Starnes Dec 5 '17 at 0:04
  • 1
    Wi-Fi is usually automatically installed. Open your terminal with <Ctrl>+<Alt>+T and type lspci -v | grep -i network copy the screen output and add it to your question. – WinEunuuchs2Unix Dec 5 '17 at 1:45
  • heidy@heidy-HP-Laptop-15-bs0xx:~$ lspci -v | grep -i network 02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device d723 heidy@heidy-HP-Laptop-15-bs0xx:~$ – heidi silva Dec 5 '17 at 5:47
  • 2
    The requested command does not identify the WiFi device correctly. Please edit your question and add output of lspci -knn | grep Net -A3 terminal command instead. – user692175 Dec 5 '17 at 17:35
  • 3
    The bluetooth device can also be activated. See askubuntu.com/questions/1033968/… – Pilot6 May 9 '18 at 10:28
22

You may use the driver hosted at Larry Finger's rtlwifi_new git repository. You would have to disable secure boot from the the BIOS/EFI first. Also make sure you have linux-headers for the respective kernel(s) and build-essential package installed. Then follow the steps below (you need to be connected to the internet by some other mean).

  1. Install git and dkms if they're not installed by running

    sudo apt install git dkms
    
  2. Clone the repository

    git clone -b extended --single-branch https://github.com/lwfinger/rtlwifi_new.git
    
  3. Run the following commands to install

    sudo dkms add rtlwifi_new
    sudo dkms install rtlwifi-new/0.6
    
  4. Reboot.

This should also work with newer kernels (and hence on Ubuntu 18.04 too).

Note: If you get very weak signal try changing your antenna selection

sudo tee /etc/modprobe.d/rtl8723de.conf <<< "options rtl8723de ant_sel=2"

(or ant_sel=1 if 2 doesn't help).

(Source)


See this for Bluetooth: How to activate bluetooth device for RTL8723DE?

  • 1
    This worked for me. The laptop I use is HP BS180TX. Ubuntu version 18.04 LTS. Kernel 4.15.0-20-generic. – arshad May 8 '18 at 18:28
  • 1
    The DKMS install is preferable. I suggest leaving only the DKMS way or explaining that. Newbies run all the commands and have trouble. – Pilot6 Jun 6 '18 at 21:27
  • it mount the interface under /sys/class/net and ip link show the wireless listed, but i can't ip link set interface up, itsn't not effective, any idea why? – Error Sep 18 '18 at 16:46
  • unix.stackexchange.com/questions/469809/… can you help? – Error Sep 18 '18 at 18:15
  • 1
    This worked for me. My laptop model is 15q-ds0009TU – Vishal Zanzrukia Dec 29 '18 at 13:07
11

There is new information on this device! With a temporary working internet connection, open a terminal and do:

sudo apt update
sudo apt install build-essential dkms git
git clone https://github.com/jeremyb31/rtl8723de.git
sudo dkms add ./rtl8723de
sudo dkms build rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414
sudo dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414

Reboot and let us hear your report.

This won't work for Ubuntu 18.04 because of the new kernel incompatibility.

  • I think dkms install is necessary too (which invokes build if necessary). – David Foerster Feb 8 '18 at 14:40
  • 3
    when I'm trying to execute last command it shows this: Kernel preparation unnecessary for this kernel. Skipping... Building module: cleaning build area.... 'make' all KVER=4.15.3-041503-generic....(bad exit status: 2) ERROR (dkms apport): binary package for rtl8723de: 5.1.1.8_21285.20171026_COEX20170111-1414 not found Error! Bad return status for module build on kernel: 4.15.3-041503-generic (x86_64) Consult /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/make.log for more information. – Jay Patel Feb 12 '18 at 13:18
  • @JayPatel I suggest that you start your own new question and include the result of: dkms status. – chili555 Feb 12 '18 at 13:52
  • When I tried this got an error when executing the 5th command. ERROR (dkms apport): binary package for rtl8723de: 5.1.1.8_21285.20171026_COEX20170111-1414 not found Error! Bad return status for module build on kernel: 4.15.0-20-generic (x86_64) Consult /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/make.log for more information. – arshad May 8 '18 at 16:52
  • @arshad suggest that you start your own new question and include the result of: cat /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/make.log – chili555 May 8 '18 at 17:57
0

If you want to keep secure boot enabled, then the previously posted solutions probably will not work for you. Instead I kept secure boot enabled and did the following:

Create a set of keys for signing:

openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=Descriptive common name/"

Import the key. You'll be prompted for a password here, which you'll need to remember. Your BIOS should prompt you for the password after the reboot.

sudo mokutil --import MOK.der

Restart:

reboot

You should have been prompted by your BIOS for the password. Assuming that worked, then you'll want to test that your MOK was successfully enrolled.

mokutil --test-key MOK.der

Now that your MOK has been enrolled. You'll need to install the drivers for you wifi.

git clone https://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
git checkout extended
sudo make install

You're drivers are available for adding to your kernel, but you need to sign them first before adding them because you have secure boot enabled. So use the keys you generated earlier to sign your drivers.

sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n rtlwifi)
sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n rtl_pci)
sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n btcoexist)
sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n rtl8723-common)
sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n phydm_mod)
sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n rtl8723de)

Finally, add the rtl8723de drivers to the kernel in this order

sudo modprobe -r rtlwifi
sudo modprobe rtlwifi
sudo modprobe -r rtl_pci
sudo modprobe rtl_pci
sudo modprobe -r btcoexist
sudo modprobe btcoexist
sudo modprobe -r rtl8723-common
sudo modprobe rtl8723-common
sudo modprobe -r phydm_mod
sudo modprobe phydm_mod
sudo modprobe -r rtl8723de
sudo modprobe rtl8723de

On a side note: for the final step you might be able to get away with just writing:

sudo modprobe -r rtl8723de
sudo modprobe rtl8723de

modprobe knows which drivers rtl8723de depends on and should therefore be able to add everything that rtl8723de depends on along with rtl8723de. However, I didn't add my drivers this way and thus, can't guarantee this option will work.


Sources: 1, 2, 3

protected by Community Jan 23 '18 at 16:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.