1

I am not able to change the screen brightness on lenovo z570.

Even the function keys for the brightness are also not working. Any idea ?

4

Try switching off Num Lock.

With my z570 xubuntu the brightness keys are without function if Num Lock is active. When i switch it off every thing works fine.

3

Finally got the brightness controls to work properly!

The issue persists due to presence of two backlight modules acpi_video0 and intel_backlight. You can cross check if both modules exists by running the below command.

ls /sys/class/backlight/

If you find acpi_video0 as one of the modules run the command:

sudo tee /sys/class/backlight/acpi_video0/brightness <<< 5

If no change is observed, it is time to remove this module. My assumption is that by default intel_backlight is ignored and acpi_video0 is being used by the kernel for handling backlight.

Sometimes, ACPI does not work well due to different motherboard implementations and ACPI quirks. This includes some laptops with dual graphics (e.g. Nvidia/Radeon dedicated GPU with Intel/AMD integrated GPU).

On Nvidia Optimus laptops, the kernel parameter nomodeset can interfere with the ability to adjust the backlight. Additionally, ACPI sometimes needs to register its own acpi_video0 backlight even if one already exists (such as intel_backlight), which can be done by adding one of the following kernel parameters in your bootloader:

acpi_backlight=video
acpi_backlight=vendor
acpi_backlight=native

Source

Since acpi_video0 backlight did not change the brightness, you may need to use acpi_backlight=none as an argument as well. This line disables the acpi_video0 module from kernel parameters so that only intel_backlight handles the brightness controls.

You need to modify the bootloader file /etc/default/grub to add the above mentioned arguments. It should look something like this.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=native"                     

In case native does not work try with video, vendor, or none.

Update the grub configuration:

sudo update-grub

Reboot your system, the brightness controls should now work.

More details on my blog.

9
  • @DavidFoerster: My apologies as I have posted here for the first time. I have updated the answer.
    – Nisheet
    Jul 13 '16 at 7:32
  • Thanks. Much better now! If you can convincingly explain the reason for the 4 subsequent reassignments of GRUB_CMDLINE_LINUX erasing the previous assignment to me, I'll vote for your answer. Additionally, as a rule of thumb one should add non-essential kernel parameters in GRUB_CMDLINE_LINUX_DEFAULT instead of GRUB_CMDLINE_LINUX. Jul 13 '16 at 8:04
  • @DavidFoerster Done changes as per review!
    – Nisheet
    Jul 13 '16 at 17:50
  • You're still specifying the acpi_backlight option multiple times with different values even though only one of them will be used (either the first or the last). What do you hope to achieve with that? Did you read the text that you cited? It says that you should “add[…] one of the following kernel parameters” (highlight by me). Jul 13 '16 at 23:26
  • Done with the changes.
    – Nisheet
    Jul 15 '16 at 18:51
2

If all else fails, you might want to try out the command-line utility xbacklight.

You can install it by running

sudo apt-get install xbacklight

Then if you want to make the screen brighter you can type

xbacklight +50

(or replace 50 with whatever percentage you'd like)

Or if you wanted to dim the screen you can type

xbacklight -50

etc.

Also if you really had the time, you might want to mess with key-bindings to make running those commands more convenient.

2
  • i got the following message <No outputs have backlight property>
    – krishna
    Jan 26 '12 at 6:17
  • @krishna From your tag, I presume you are using Nvidia? I actually don't have an Nvidia machine, but can you get to Nvidia X Server settings? If you can, going under X Server Diplay configuration > X Server Color correction might help, according to link
    – math4tots
    Jan 27 '12 at 6:16
1

Try the following and see if after a reboot your brightness keys are functional again. Edit etc/X11/xorg.conf and add the another line to the Device section: Option "RegistryDwords" "EnableBrightnessControl=1"

1
  • there is no such file!!
    – krishna
    Jan 26 '12 at 6:15
0

I also have a Lenovo z570 and this worked for me with 16.04 and now with 18.04.

The problem in my case is because the system has added the acpi_video0 module incorrectly, and the brightness keys use this module instead of correct one for my hardware (intel_backlight).

See my full answer here.

To cut a long story short, for the z570, the answer is to add the boot option acpi_backlight=none which will remove the directory acpi_video0 from /sys/class/backlight/. This makes the system use /sys/class/backlight/intel_backlight as required.

1
  • Now tested successfully on Ubuntu 20.04.
    – ianinini
    May 8 '20 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.