0

I followed this tutorial to install OpenVPN on my home server. However, this is the behavior that I'm getting:

UDP:

When I make the protocol UDP, as in the tutorial, this is what happens: When I connect to it with my Windows 10 laptop, the OpenVPN GUi stays green, but I cannot connect anywhere. Not even to the server's IP addresses (through the VPN or otherwise). It just stays like that.

TCP:

When I make the protocol TCP, this is what happens: When I connect to it with my Windows 10 laptop, initially OpenVPN GUI becomes green an everything seems fine. However, at this point the laptop cannot connect anywhere. Even the existing SSH connection to this server hangs. Then, after a bit, I get this in the client logs:

Tue Dec 05 02:04:07 2017 read TCP_CLIENT: Unknown error (code=10060)
Tue Dec 05 02:04:07 2017 Connection reset, restarting [-1]
Tue Dec 05 02:04:07 2017 SIGUSR1[soft,connection-reset] received, process restarting
Tue Dec 05 02:04:07 2017 MANAGEMENT: >STATE:1512428647,RECONNECTING,connection-reset,,,,,
Tue Dec 05 02:04:07 2017 Restart pause, 5 second(s)

And OpenVPN GUI becomes yellow. After disconnecting the OpenVPN client, my existing SSH session usually starts working again without breaking.

What may be going wrong? It feels like something on the server is preventing connections. I have an EarthVPN account and I can connect to it via OpenVPN in this laptop just fine. I compared the laptop's routing tables that are generated after connecting to EarthVPN and my own VPN. In my own, there is this extra line in the second place, which is not there in EarthVPN. I tried deleting it quickly with NetRouteView, but it didn't change anything. The laptop still could not connect to anywhere. I tried disabling Windows firewall, too with no luck.

At this point I'm lost... I would appreciate any suggestions that may help me debug this situation.

Edit: In the comments of the tutorial that I used, there was this link that people praised to be an easy OpenVPN install. Tried that with both TCP and UDP. Exactly the same result...

1

If you do not have access to the server, you can add the autolocal config on your client.

redirect-gateway autolocal

If you're on windows:

  • First, open the settings to figure out which config file to edit.
    • Settings -> Advanced will show you the path.
  • Open the config file.
  • Add the redirect-gateway autolocal at the end of the file.
1

Ok, figured it out. Just added the autolocal to this line in the server:

push "redirect-gateway autolocal def1 bypass-dhcp"

Thanks to this answer: https://serverfault.com/a/827497/446984

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.