4

Suddenly my GIMP 2.8.16-1ubuntu1.1 does not start any more in Ubuntu 16.04 64-bit with the latest updates as of 2017/12/04 19:48

Once I start it from the command line, it just says:

Segmentation fault (core dumped)

From the GUI it does nothing.

I searched for hours on the internet and found a way to debug it:

gdb gimp
(gdb) run

The output is the following:

Starting program: /usr/bin/gimp 

Program received signal SIGSEGV, Segmentation fault.
_dl_relocate_object (scope=0x7ffff7fd7358, reloc_mode=<optimized out>, 
    consider_profiling=consider_profiling@entry=0) at dl-reloc.c:232
232 dl-reloc.c: Datei oder Verzeichnis nicht gefunden.

"Datei oder Verzeichnis nicht gefunden" is German and means "No such file or directory".

I really don't know what I should do! I already tried re-installing GIMP but I even didn't update it before the failure happened!

However I recently updated some libc stuff which ubuntu's update dialog suggested me.

I don't use GIMP that often but before the update it worked. Maybe it has something to do with the update?


apt-cache policy gimp:

gimp:
  Installed:           2.8.16-1ubuntu1.1
  Installation candidate: 2.8.16-1ubuntu1.1
  Version table:
 *** 2.8.16-1ubuntu1.1 500
        500 http://de.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
        100 /var/lib/dpkg/status
     2.8.16-1ubuntu1 500
        500 http://de.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

uname -a:

Linux user01 4.4.0-101-generic #124-Ubuntu SMP Fri Nov 10 18:29:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

arch: x86_64

sudo apt-get check:

   Paketlisten werden gelesen... Fertig
   Abhängigkeitsbaum wird aufgebaut.       
   Statusinformationen werden eingelesen.... Fertig

This basically means that everything should work fine. The dependency tree is being built, status information are read and package lists are read as well.

My /etc/apt/sources.list.d/ does not contain anything. And I don't think that I'm using any PPA. However I installed VirtualBox, Android Studio and so on. Everything could be the problem!

  • 1
    Very strange. Please update your post with output of apt-cache policy gimp, uname -a, arch, sudo apt-get check. On my 64-bit Xenial GIMP (2.8.16-1ubuntu1.1 from universe) works good. Do you have any PPAs (add ls /etc/apt/sources.list.d/*.list to the answer)? – N0rbert Dec 4 '17 at 19:04
  • 1
    My gimp version 2.8.16-1ubuntu1.1 works well in Xenial 32-bit too, and it is updated and full-upgraded today. I would suspect some special library. – sudodus Dec 4 '17 at 19:07
  • 2
    dl-reloc.c file is located in the glibc internals. Do you have custom kernel? Do not forget to add output of other command from my comment above. – N0rbert Dec 4 '17 at 19:19
  • 2
    This could be a clue: "However I recently updated some libc stuff which ubuntu's update dialog suggested me."; But maybe it is something very different. Maybe some file is damaged or some sector on the hard disk drive. (ninja'd by N0rbert;-) – sudodus Dec 4 '17 at 19:27
  • 2
    OH! Gimp-Edge works! I don't know why! But it works! – fameman Dec 4 '17 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.