2

I was copying some movies to SD card suddenly my friend fell on to my laptop and SD card got removed from the laptop while copying. Now the SD card is showing is showing only two files in it and it can be accessed. But now the when I format the memory card its still showing the two files. I tried deleting it and it gets deleted but when i plug in the memory card again the files again appear in the memory card. Cannot format it. I have tried deleting the partition and created the new partition but still the SD card is damaged.

marked as duplicate by user68186, Eric Carvalho, user117103, Zanna, David Foerster Dec 15 '17 at 11:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • It looks like the card is gridlocked. But you should try several ways to make it work before giving up. See this link and links from it, askubuntu.com/questions/144852/… - There is a list of things to try: "The drive is read-only: ..." – sudodus Dec 4 '17 at 19:41
  • This answer to a similar question looks like it may answer yours. askubuntu.com/questions/511467/… – Amber Dec 4 '17 at 19:47