I just installed Ubuntu server 11.10 and the install went fine. This system is running on an Intel Pentium II board with onboard graphics.

However when I try to boot into Ubuntu I get a white terminal with garbled black text. I have tried various grub 'fixes' as googling the issue seemed to suggest it was a res or grub related issue.

I cannot ssh in so the issue does affect Linux as well.

I have had no luck with anything thus far and am at my wits end. This was my first Ubuntu excursion as my friend told me it was better for servers than CentOS because it was easier... Not so much....

Does anyone have any ideas as to what the issue could be? When answering bear in mind I am an Ubuntu noob and Linux novice.

As of 1/26/12 I have tried to add the console=ttyl line to the /etc/default/grub and run update-grub. This results in the line in the boot parameters that normally reads:

linux /vmlunz-3.0.0-12-generic-pae root=/dev/mapper/dev-root rovt.handoff=7

now reads:

linux /vmlunz-3.0.0-12-generic-pae root=/dev/mapper/dev-root ro console=ttyl vt.handoff=7

This does not work. Is there anyway to have console=ttyl inserted on a line by itself? I am at my wits ends, Thanks for all your help, Speed

  • Whats a vt? Its an onboard video controller, Intel Pentium II board. – SpeedCrazy Jan 25 '12 at 1:12
  • Ctlr-alt-f2 worked. IS there a permanent workaround as this is a normally headless server and i cant do that every time i need to reboot. – SpeedCrazy Jan 25 '12 at 1:28
  • That works, thanks so much. Care to explain what that does? I am trying to learn here not just make it work. – SpeedCrazy Jan 25 '12 at 2:24
  • 11.10 is end of life, and you should update your system to a supported release such as 12.04 – Thomas Ward Aug 18 '13 at 15:48

Try adding console=tty1 to your boot options on the kernel line.

Edit /etc/grub/defaults and add that to the options line

sudo -e /etc/grub/defaults

Edit the following line (splash is optional)

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash console=tty1"

The problem you seem to be having is with your graphics driver and framebuffer

There is a bug report here (I think you have a similar problem, just with a different intel card is all).


I merely posted an alternate work around.

With that I have told you more then I know about this bug.

  • That file /etc/grub/defaults does not exist. – SpeedCrazy Jan 25 '12 at 14:45
  • Found that line in /etc/default/grub but it did not put console=ttyl in the right place it was on the linux/vz whatever line in the parameters. Would not boot like that. – SpeedCrazy Jan 25 '12 at 15:44
  1. Tap escape during boot to get to the grub menu and select an older version with recovery mode

  2. Add nomodeset and xforcevesa to your grub config in /etc/default/grub (see the below on how to do that) Related: nvidia-96 drivers causing garbled text, display on Geforce4 Ti 4660

  3. Uncomment in grub config the line that enables GRUB_TERMINAL=console (i.e. don't use graphics in the grub menu)

  4. sudo update-grub

  5. Reboot

  • Just wanted to say that this fixed my problem. I was installing Linux Mint 17.2 XFCE on a HP Stream 13. I had used boot-repair to fix a broken GRUB build, but was getting garbled text on a white screen with vertical black bars. I tried everything here, and more, but ultimately your solution fixed my issue. GRUB_TERMINAL=console did the trick! Thanks Jon! – Rob Gibbons Dec 14 '15 at 0:04

You might have already found a solution for your problem. If so please share.

Here's something that somewhat worked for me. I had reached to that solution after all the googling and following of the link given by Jon Vaughan above and other answers over there. Thanks @all for that.

Here's what i did,

  1. During boot hold SHIFT to see GRUB menu

  2. Press e to edit You will see something like this.

        gfxmode $linux_gfx_mode
        insmod gzio
        insmod part_msdos
  1. I replaced $linux_gfx_mode with 800x600

  2. press CTRL+x to boot

Note: The resolution 800x600 means nothing here. I had tried 1024x768 instead, but it gave same result. No change in resolution of terminal/display. But I no longer found garbled text on my monitor.

This is a temporary solution. If this worked for you, you can make permanent changes like i did. By looking into /etc/grub.d/10_linux, i found that $linux_gfx_mode in /boot/grub/grub.cfg was being set by a variable GRUB_GFXPAYLOAD_LINUX. So,

  1. edit /etc/default/grub

  2. Add this line at the end GRUB_GFXPAYLOAD_LINUX=800x600

  3. sudo update-grub

  4. sudo reboot

Note: From the /boot/grub/grub.cfg it seems the variable $linux_gfx_mode is supposed to have values like keep or text, so 800x600 is not something thats expected. So, it might be that the system falls back to some default value, which solved my problem ;-)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.