I have Ubuntu 14.04 running in a VMware Workstation VM. While attempting to resize some partitions I decided I needed to get shared folders to work properly, so I clicked VM > Reinstall VMware Tools and followed the prompts to install VMware Tools. That worked and shared folders started working. After restarting, however, I now get a black screen after logging in. First I thought the whole VM was locking up but then I discovered that making the VMware window smaller than a certain size made the desktop appear, and making it larger again makes the VM go black. It also displays an error message:

Could not configuration for CRTC 63

What could be causing this and how do I fix it?

  • I had a lot of trouble solving this problem myself and could find no information of anyone else having the same issue, so I'm doing a self-answered question in the hopes no one else has to go through the same pain.
    – Clonkex
    Dec 4, 2017 at 3:05

4 Answers 4


Somehow I came across this answer to an unrelated question, and it helped fix my issue. It seems as though when VMware knows it has VMware Tools installed it stops handling certain resolutions correctly. All I did was open my VM's vmx file (after shutting down the VM of course, since the file is overwritten on shutdown) and changed this line:

svga.guestBackedPrimaryAware = "TRUE"

...to this:

svga.guestBackedPrimaryAware = "FALSE"

And now I can maximise the VMware window again and the guest resizes correctly. Shared folders also still appear to work.

More information about vmx files:

https://kb.vmware.com/s/article/1714 https://www.vmware.com/support/ws5/doc/ws_learning_files_in_a_vm.html


This, among many other solutions didn't work for me. I ended having to uninstall vmware tools.


  1. Once at the black screen, press Ctrl + Alt + F1 to return to the Command Line
  2. Run sudo /usr/bin/vmware-uninstall-tools.pl (it took a few minutes to finish for me, be patient)
  3. Reboot

VMware Tools Uninstall Ref: https://kb.vmware.com/s/article/1014522


OK try this. I found the monitor resolution setting on the VM was set to 'use host settings for monitors'. Which in my case was quite high. Set to 'SPECIFY MONITOR SETTINGS'. Such as 1280x1024. Then reduce resolution to something less until the Virtual Machine can Handle and it should now display things properly.

VMWARE WORSTATION PLAYER 16.1.2 build-17966106

  • Are you aware that you're responding to a question that's four years old and referring to a Ubuntu version long out of support?
    – Tilman
    Oct 11, 2021 at 19:42
  • Yes, thanks for checking. It's a common problem for many people and with many platforms such as Windows. So i thought id post anyway in case it might help someone. (this post comes up in Google results when searching for Black Window in VMWARE Workstation Player or similar.
    – Rob C UK
    Oct 11, 2021 at 19:46

I just set video card to "auto" on the VM settings.
Did the job for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .