1

I have an NTFS external HD. Recently I put in Windows everything inside a folder in it as the OneDrive folder. Mounting the HD in ubuntu, it failed to open the folder. unsupported reparse point in ls -l. I updated the NTFS-3g to the most recent version https://www.tuxera.com/community/open-source-ntfs-3g/, which didn't work to open the folder. Link to unknown in Nautilus. I installed a plugin https://github.com/ebiggers/ntfs-3g-system-compression that here https://bugzilla.redhat.com/show_bug.cgi?id=1377049 is posted as a solution to a related problem but didn't work. I had previously perceived, that common OneDrive folders in C:/Users are not seen in ubuntu dual boot.

EDIT: Related answer in Github https://github.com/ebiggers/ntfs-3g-system-compression/issues/4#issuecomment-352199648

EDIT2: Somehow I can see the folder now, however, I am not sure which of the mentioned solutions was the crucial one. Sorry for that.

  • To clarify, you have an NTFS partition on an external HDD. You also use Microsoft's OneDrive service. While in Windows, you moved everything on the HDD into the OneDrive folder. Is that correct? It sounds to me like the visible folder is actually just a link to somewhere else. Have you tried viewing hidden folders/files and searching them for your files? Also note, I am guessing that your files probably won't synchronize while in Ubuntu. – Andrew Shum Dec 3 '17 at 16:08
  • 1
    I think it is not related to a "link" issue. See edit. As I wrote, folder is not completely hidden but they cannot be accessed. I am not expecting it to synchronize in ubuntu, just to read it. – Ferroao Dec 3 '17 at 16:29
  • I am not sure what to tell you then. Usually Ubuntu lets you see and access more than Windows; not less. The only exception I can think of is if the "folder" is in some format not recognized by Ubuntu. However, this shouldn't be the case with basic files/folders. – Andrew Shum Dec 4 '17 at 17:58
0

I'm having the same problem on my Ubuntu (all versions) in dual boot with Windows 10 and OneDrive folder on a shared NTFS partition. Seems that Windows 8.1/10 OneDrive clients create some sort of virtual volume, while the folder on the disk is just a new type of reparse point for that volume.

I've compiled and installed this NTFS 3g plugin specifically designed for OneDrive (just search for onedrive on the page)

0

I found a different solution.

  1. In Windows, go to the settings for OneDrive, and untick the option to Save space and download files as you use them on the Settings tab.
  2. Sign out of your OneDrive account (this should save your settings)
  3. Go to your OneDrive folder (C:\Users\\OneDrive), and delete or move the folder to a different location.
  4. Reboot your PC.
  5. Sign back into OneDrive, and let the sync complete.
  6. Boot into Linux, and the folders and files should be accessible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.