I have an old HP Laserjet 6MP that I am trying to use with an IEEE 1284 -> USB cable. I plug it in and turn it on before booting into Kubuntu and I get some likely candidates in /dev/: parport0, parport1, lp0, lp1

Following advice I've seen elsewhere on the web, I have tried setting the URI to all combinations of [parallel, serial, usb]:/dev/[parport0, parport1, lp0, lp1] but haven't been able to get a test page to print ever.

Any ideas on how else I can trouble shoot this?

  • I ran dmesg and got output like this: [69623.668702] uss720: async_complete: urb error -32 [69623.668725] get_1284_register: usb error -32 Repeated over and over. The 1284 part means its about my usb-serial cable...? Perhaps it is faulty? – evencoil Jan 25 '12 at 17:55

Try adding the line

blacklist uss720

to /etc/modprobe.d/blacklist.conf.

This worked for me on Fedora 17 and 18, where the uss720 module caused me problems. Once I did this and rebooted, Fedora found my Laserjet6L and configured it automatically.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.