I have installed the Adapta theme.

I successfully enabled the Adapta Nokto them on the GDM3 Login Screen using:

sudo update-alternatives --install /usr/share/gnome-shell/theme/gdm3.css gdm3.css /usr/share/themes/Adapta-Nokto/gnome-shell/gdm3-Adapta-Nokto.css 1
sudo update-alternatives --config gdm3.css

This, of course, shows the Adapta Nokto theme whenever I need to log into my system.

However, if I lock my screen, the default gnome-shell theme is shown (/usr/share/gnome-shell/theme/gnome-shell.css).

How can I make the Lock Screen use the Adapta-Nokto theme (/usr/share/themes/Adapta-Nokto/gnome-shell/gdm3-Adapta-Nokto.css)?

Note: My system desktop theme is set to Adapta, and my gnome-shell theme (top bar and dock) is is set to Adapta-Nokto (because I am using the User Themes extenson).


The solution is to use the gnome-shell-theme.gresource file from the Adapta-Nokto theme.

EDIT: I updated this solution to create a link to the Adapta-Nokto gnome-shell-theme.gresource theme file, instead of copying it. This way, the Lock screen will always use the most recent version of the Adapta-Nokto theme, whenever it is updated.

  1. Open a terminal, and change to the gnome-shell directory.

    cd /usr/share/gnome-shell/
  2. Backup the original gnome-shell-theme.gresource file. The following command will only create the backup, if the current file is not a link (created using step 3).

    if ! [[ -h gnome-shell-theme.gresource ]]; then sudo mv gnome-shell-theme.gresource gnome-shell-theme.gresource.original; fi
  3. Link to the Adapta-Nokto theme's gnome-shell-theme.gresource file.

    sudo ln -frs /usr/share/themes/Adapta-Nokto/gnome-shell/gnome-shell-theme.gresource gnome-shell-theme.gresource
  4. Reboot to enable the new Lock screen. (Just loging-out and logging-back-in is not sufficient to enable the new Lock screen, because you are repeatedly taken back to the Login screen after you enter your password).

  5. Note: if the gnome-shell-common package is updated at a future time, you may need to execute steps 1 thru 3 again to re-enable the Adapta-Nokto Lock screen theme.

Reference: Materia GDM Theme

| improve this answer | |
  • Didn't work immediately for me; however, referring to the Materia GDM theme link provided, helpfully pointed out that the file /usr/share/gnome-shell/theme/ubuntu.css also needs replacing (I'm on Bionic). I used a similar technique to above (my theme is Pop), so: cd /usr/share/gnome-shell/theme && mv ubuntu.css ubuntu.css.ORIG && ln -s /usr/share/themes/Pop/gnome-shell/gnome-shell.css ubuntu.css. Followed by Alt+F2 then rt (reboot wasn't needed) and presto, it works! – sxc731 Aug 12 '18 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.