0

I had recently installed Ubuntu on my Sager Notebook Computer , and I noticed after a while that there was a LOT of screen tearing on my PC. I started researching the topic and found a lot of solutions. The first thing I tried was installing nvidia drivers using

sudo apt-get install nvidia-current

This did not fix my problem.

I then tried to change the settings in Nvidia X Server Settings, but it said that "PRIME Displays cannot be controlled by nvidia-settings and must be configured by an external RandR capable tool. The display is shown in the layout window for information purposes only"

Nvidia X Server PRIME Display Issue Screenshot

I then tried to install CompizConfig and change the refresh rate to >144 Hertz, but that also did not effect anything.

After some more research I tried to use the xrandr command to change the refresh rate, but that also had no effect.

I tried to disable Wayland and enable GDM3, yet that also yielded no change.

I then tried installing Bumblebee in hopes of fixing the sync, but that had no effect, and even Soft-Bricked my computer later.

Here are my specs : http://www.sagernotebook.com/Notebook-NP7870.html

  • Did you take a look at possible solutions like askubuntu.com/questions/941077/screen-tearing-on-nvidia-gtx960m – ubfan1 Dec 3 '17 at 4:05
  • yes I did indeed – AutoBootDisk Dec 3 '17 at 4:44
  • The Nvidia X Server Settings have no options – AutoBootDisk Dec 3 '17 at 4:44
  • That's because you installed the wrong Nvidia drivers. The nvidia-current actually is 340, an old driver with extended support only to used for legacy hardware and that certainly isn't the case. – user692175 Dec 3 '17 at 14:02
  • 1
    UPDATE I found the solution to my problem HERE : ubuntuforums.org/showthread.php?t=2365449 Don't worry if the file /etc/modprobe.d/zz-nvidia-modeset.conf is missing, just create it if it is. – AutoBootDisk Dec 3 '17 at 21:50
-1

I found the solution to my problem HERE.

Don't worry if the file /etc/modprobe.d/zz-nvidia-modeset.conf is missing, just create it if it is.

  • Note that starting in 18.04 you no longer specify driver version. Ex. of doing via a .conf here, otherwise one can add to grub's linix command line. ubuntuforums.org/… (-also note that users should note upgrade drom 17.10 to 18.04 with nvidia drivers installed, problems will occur. 18.04 is best served on a fresh install.. – doug Apr 12 '18 at 1:35
  • Please do not post answers that depend on a link. Include the important information directly into your answer. How to Answer – Melebius Apr 12 '18 at 5:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.