I just installed kubuntu 17.10 on a lenovo Y700 laptop, and tried to install nvidia driver by doing :

sudo apt-add-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt purge 'nvidia-*'
sudo apt install linux-headers-$(uname -r)
sudo apt install nvidia-384

After restarting, it results in a black screen.

1) How can I have at least to a Konsole, or an ssh connection to the laptop in order to uninstall nvidia drivers and try fixes? Indeed I have been doing fresh installations o kubuntu several times now?

2) Any fix for this issue? my NVIDIA is GTX 960M

Thanks or help


I believe you did everything right, only do

sudo apt purge nvidia* 
sudo apt update 
sudo apt upgrade 
sudo ubuntu-drivers autoinstall

Also if you have been doing fresh reinstallations of Kubuntu and failing, try opening Gparted or another partition manager on the live USB version, then delete all Kubuntu partitions. Then reinstall the OS.

  • Thanks... I have been reinstalling the OS or 5 times now. As or the nvidia version, I checked on nvidia's site that 384 is the current version for my system – volatile Dec 3 '17 at 1:57
  • Try the solution and tell me if it works – AutoBootDisk Dec 3 '17 at 2:09
  • I tried it. It turns out that it selects the version 304 of the driver, even i a research on nvidia's site indicates version 384. I could restart the pc and boot into it after installation, but I cannot be sure that the driver is indeed loaded and used. or example, trying a command like 'nvidia-smi' results in ile not foud – volatile Dec 3 '17 at 2:18
  • You should be able to see Nvidia X Server Settings in the apps list after a reboot – AutoBootDisk Dec 3 '17 at 2:21
  • I try that. For the moment, clicking on the K menu reezes the computer.. – volatile Dec 3 '17 at 2:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.