11

I have just downloaded and installed a fresh Ubuntu 17.10 server system.

Upon running sudo apt update and sudo apt upgrade I happened to notice these two warnings:

WARNING: Setting CRYPTSETUP in /etc/initramfs-tools/initramfs.conf is deprecated and will stop working in the future. Use /etc/cryptsetup-initramfs/conf-hook instead.

and

cryptsetup: WARNING: target cryptswap1 has a random key, skipped

I have no idea what this is, but I would like to prevent any trouble in the future. Note that I'm using full disk encryption, I assume this has to do with that. If I check the /etc/initramfs-tools/initramfs.conf file, the string crypt does not occur at all.

What am I supposed to do? And the fact that my swap partition is using a random key (at least that's how I interpret that warning), it that supposed to be the case? If not, how do I fix that?

15

The first warning is due to conflicting settings in packages overlayroot and cryptsetup. (CRYPTSETUP is set by a hook, /usr/share/initramfs-tools/conf-hooks.d/overlayroot, that's why you did not find it in initramfs.conf.) I have opened a bug on this issue. Don't worry about it, it is purely cosmetic.

The second warning comes from the way the installer sets up swap space. If swapon -s shows that your swap space is active, then you can ignore it.

2
  • 1
    Thanks. swapon -s shows this, I suppose that's good? (or is the 'Used' column being 0 bad news?) – RocketNuts Dec 2 '17 at 23:58
  • 2
    It's perfectly fine. (Swap space should be available in order to avoid bad things happening if all RAM is used up, but the system won't actually use it unless it needs it.) – AlexP Dec 3 '17 at 0:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.