1

I have recently had this issue which was not present before, I have 2 hard drives which are mounted to mount locations. Today I have noticed that I cannot create folders on these hard drives and I suspect it to be something to do with rw. I have tried to remount the hard drives but no luck.

Here is a snippet of my fstab file below:

/dev/disk/by-uuid/54E897EBE897C99E /mnt/Seagate2TB auto rw,nosuid,nodev,nofail,x-gvfs-show 0 0

/dev/disk/by-uuid/6FE61AA33CE08554 /mnt/6FE61AA33CE08554 auto nosuid,nodev,nofail,x-gvfs-show 0 0

Please can someone assist me, I have tried to look on google and I cannot find a solution.

0

Update:

I found a solution. These are the steps I took.

  1. List all the mount points mount -v | grep "^/" | awk '{print "\nPartition identifier: " $1 "\n Mountpoint: " $3}'
  2. Fix the ntfs partition sudo ntfsfix Partition Identifier
  3. Unmount the partition sudo umount Mountpoint
  4. Mount it sudo ntfs-3g PartitionIdentifier Mountpoint

Hope this helps!

  • You could have add that the problem was a corrupted NTFS partition that should have been corrected with Windows tools. ntfsfix is quite limited and using it doesn't mean the partition is fine now (it most likely isn't), just that it can be mounted but expect other issues down the road. – user692175 Dec 3 '17 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.