2

Today was my first contact with Linux OS (I pretty much do not know anything about Ubuntu). I installed Ubuntu 16.04.3 dual boot with windows 10 and everything was working. When I tried to change the screen brightness it went dark and the keys for changing brightness are not working.

I have already tried the following solutions:

Brightness key not working Ubuntu 16.04 LTS - Exactly same problem as me, except my laptop is Lenovo IdeaPad P400 touch

Can't change brightness in Ubuntu 16.04 LTS - Tried both the solution given by @Archisman Panigrahi and by @Serge Stroobandt

Ubuntu 14.04 brightness problem (Lenovo Z500) - tried solution given by @Lorenzo Gabriele. Solution similar to second link

That same problem happened to me on windows every time I updated the system. The solution was to go the video driver setting and apply the old version of the driver. I tried the similar thing:

Additional Drivers 

But the only thing in the list is 'Unknown:unknown'. In other words, no graphical drivers as shown for the answer in this question.

Moreover, I read here that "Intel graphics driver is part of the xserver-xorg-video-intel driver package", but when I execute the following:

sudo apt-get install xserver-xorg-video-intel

I get E: Unable to correct problems, you have held broken packages. as shown below:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-video-intel : Depends: xorg-video-abi-20
                            Depends: xserver-xorg-core (>= 2:1.17.99.902)
E: Unable to correct problems, you have held broken packages.
1

I could not find a solution yet, but here is a workaround that works pretty well. I took the steps belows to control brightness from the keyboard with brightness-indicator software:

  1. Download and install Intel Graphics Update Tool for Linux

    Run the tool to dowwload and upgrade drivers

  2. Get and update latest mesa drivers

    sudo add-apt-repository ppa:ubuntu-x-swat/updates
    sudo apt update && sudo apt dist-upgrade
    
  3. Create a new file

    sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf
    

    and paste the following

    Section "Device"
            Identifier  "card0"
            Driver      "intel"
            Option      "Backlight"  "intel_backlight"
            Option      "AccelMethod" "sna"
            Option      "TearFree" "true"
            Option      "DRI" "3"
            BusID       "PCI:0:2:0"
    EndSection
    

    Close and save the file

  4. Modify and update grub

    sudo gedit /etc/default/grub
    

    and set

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
    

    Then run:

    sudo update-grub
    
  5. Install indicator-brightness

    sudo add-apt-repository ppa:indicator-brightness/ppa
    sudo apt-get update
    sudo apt-get install indicator-brightness
    
  6. Create keyboardshortcut

    Setting > keyboard > shortcuts > Custom shortcuts > '+'`

    • Name: Up brightness
    • Command: /opt/extras.ubuntu.com/indicator-brightness/indicator-brightness-adjust --up

    and

    • Name: Down brightness
    • Command: /opt/extras.ubuntu.com/indicator-brightness/indicator-brightness-adjust --down
  7. Click on 'disable' to set the keyboard shortcut

| improve this answer | |
0

I input:

sudo dpkg --configure -a

and then my brightness setting back to normal.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.