0

I have a UEFI system.I installed Ubuntu as a dual boot. I followed this https://itsfoss.com/install-ubuntu-1404-dual-boot-mode-windows-8-81-uefi/ tutorial. As for the tutorial it says if I don't get Grub as bootloader I have to run bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi in cmd in windows.

As I didn't get Grub as the bootloader after the installation I ran the command in Admin prompt in windows. But still I'm not getting Grub as the default bootloader. I have switched off secure boot as well.

Now if I need to switch to Ubuntu or log to Ubuntu every time I have to press F9 on startup and select Ubuntu from there so it would select grub. Then only I can log into Ubuntu.

How can I fix this ? How can I set Grub as the default bootloader.

  • 1
    open the firmware settings and change the boot order. Set the OS selection to Ubuntu and put it at the top of the list. – ravery Dec 2 '17 at 16:13
  • 2
    What brand/model system. Some will not let you set ubuntu entry as default in UEFI as they use description, and only valid description is "Windows Boot Manager". Some of the work arounds: Sony, HP & others: askubuntu.com/questions/486752/… Boot-Repair should automatically do copy file with 'use standard EFI file': askubuntu.com/questions/582073/dual-boot-but-only-windows-boots/… – oldfred Dec 2 '17 at 16:41

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.